[GRASS-user] GRASS on Mac OS 10.8.3

Adam Dershowitz adershowitz at exponent.com
Mon Apr 8 17:00:00 PDT 2013

I recently upgrade to a  new machine that has mac OS 10.8.3 on it (from 10.6).  Now, GRASS seems not to be working.  What's the status of GRASS on 10.8.3?
Here are the details.

I tried kyngchaos binary 6.4.2 and if I double click on it, I initially get:

 '/Applications/GRASS-6.4.app/Contents/MacOS/grass.sh'; exit
Rebuilding Addon HTML manual pages index...
Rebuilding Addon menu...
dyld: DYLD_ environment variables being ignored because main executable (/usr/bin/osascript) is code signed with entitlements
Python 2.6.8 found.

WELCOME TO GRASS              Version 6.4.2         2012

   1) Have at your side all available GRASS tutorials

   2) When working on your location, the following materials
      are extremely useful:
      - A topo map of your area
      - Current catalog of available computer maps

   3) Check the GRASS webpages for feedback mailinglists and more:

Hit RETURN to continue

If I then hit return I get:

Starting GRASS ...
Traceback (most recent call last):
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/wxpython/gis_set.py", line 35, in <module>
    from gui_modules import globalvar
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/wxpython/gui_modules/globalvar.py", line 76, in <module>
    import wx
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/_core.py", line 4, in <module>
    import _core_
ImportError: dlopen(/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/_core_.so, 2): no suitable image found.  Did find:
/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/_core_.so: mach-o, but wrong architecture
Error in GUI startup. If necessary, please
report this error to the GRASS developers.
Switching to text mode now.
Hit RETURN to continue...

I then tried downloading the newest 7.0 from cmbarton and ran into similar problems.  Any thoughts or suggestions?

Thanks much.

-- Adam

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20130409/d131065a/attachment.html>

More information about the grass-user mailing list