[GRASS-user] v.lidar.edgedetection, v.surf.bspline and visualization issues

Rebecca Bennett rabennett at ymail.com
Tue Aug 27 06:02:20 PDT 2013

Hello Luis,

I'm about to commit a sacrilegious act on the GRASS-user list but it would seem that Martin Isenburg's LAStools software is more appropriate for this stage of your lidar processing.


My workflow is to do the tasks you mention below (including the point cloud visualization and DEM generation) in LAStools and then import the DEM / DTM to GRASS for all subsequent processing.


Rebecca Bennett
Postdoctoral Associate, Wired! Group
Department of Art, Art History and Visual Studies
Duke University, Durham, NC

> From: Luis Ramirez <lu.ramirez.c at gmail.com>
>To: grass-user at lists.osgeo.org 
>Sent: Monday, 26 August 2013, 9:03
>Subject: [GRASS-user] v.lidar.edgedetection,	v.surf.bspline and visualization issues
>Hi there,
>I´m being working with Grass Gis just for few weeks. I´m trying to 
>generate a dsm and dtm from LIDAR data. I imported my data as LAS and i 
>was following the steps explained in the Grass Gis Book of neteler and 
>mitasova. However, I'am having some problems that are transforming an 
>easy task into a time-consuming-nightmare. the first thing that I do not 
>understand is why v.lidar.edgedetection works under Grass Gis 6.4. and 7 
>instaled in a Virtual machine with Ubuntu but not in Grass Gis 6.4. and 
>7 in a windows 7 Computer. after calculating the first two regions (from 
>9) it crashes. I tried to increment the parameters "see" and "sen" up to 
>the value 10. it is able to calculate a bit more but it still craches. 
>after googleing it i Just get information about a bug detected in 2006. 
>I would really apreciate to be able to run this module in a windows 7 
>computer. do you maybe have a clue?
>the second issue is related to v.surf.bspline. I am using a very small 
>map of 1km2 with 118798 points for testing (the goal is to use the 
>procedure for a map at least 20 times larger than this one). However, 
>Grass Gis 6.4 and 7 (for Ubuntu and For Windows) show me a warning 
>message. it says that it could take too long depending on the amount of 
>points. I already tried with different values for the parameters" sie" 
>and "sin" but it doesnt get any better. I just left the computer 
>calculating for few hours but I´m not really getting any result. do 
>anyone have an Idea what I´m doing wrong?
>Finally, I´m being trying to get a 3D visualization of the points but 
>both the monitors of the GUI and the wxs ended up crashing before I can 
>see a thing. is that a known problem? there is any known reason for such 
>a problem or even better, a solution or an alternative?
>Thank you in advance!
>grass-user mailing list
>grass-user at lists.osgeo.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20130827/a8a99946/attachment.html>

More information about the grass-user mailing list