[GRASS-user] GRASS 6.4.RC3 GUI not starting on windows & GRASS 7 not launching at all

Hanan Karam HananKaram at esinternational.com
Mon May 13 04:29:52 PDT 2013

Hi everyone,

I downloaded the Windows binary for Grass 6.4.3RC3 (dated April 20, 2013, available on http://grass.osgeo.org/grass64/binary/mswindows/native/) and installed it on my Windows PC (6-4 bit, running Windows 7).
I got the following error message on start-up.

Starting GRASS ...
Traceback (most recent call last):
  File "C:\GRASS643RC3\Python27\lib\site.py", line 563, in <module>
  File "C:\GRASS643RC3\Python27\lib\site.py", line 545, in main
    known_paths = addusersitepackages(known_paths)
  File "C:\GRASS643RC3\Python27\lib\site.py", line 278, in addusersitepackages
    user_site = getusersitepackages()
  File "C:\GRASS643RC3\Python27\lib\site.py", line 253, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "C:\GRASS643RC3\Python27\lib\site.py", line 243, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "C:\GRASS643RC3\Python27\lib\sysconfig.py", line 472, in get_config_var
    return get_config_vars().get(name)
  File "C:\GRASS643RC3\Python27\lib\sysconfig.py", line 405, in get_config_vars
    import re
  File "C:\GRASS643RC3\Python27\lib\re.py", line 105, in <module>
    import sre_compile
  File "C:\GRASS643RC3\Python27\lib\sre_compile.py", line 14, in <module>
    import sre_parse
  File "C:\GRASS643RC3\Python27\lib\sre_parse.py", line 17, in <module>
    from sre_constants import *
  File "C:\GRASS643RC3\Python27\lib\sre_constants.py", line 18, in <module>
    from _sre import MAXREPEAT
ImportError: cannot import name MAXREPEAT
Error in GUI startup. If necessary, please
report this error to the GRASS developers.
Switching to text mode now.
Hit RETURN to continue...

I also tried with the most recent WinGRASS binary snapshot: 6.4.3svn-r56225, and got the same result.

I also tried download and installing the most recent binary snapshot of winGRASS 7: r56229, and that wouldn't start at all.

I have winGRASS 6.4.3 RC2 working fine on my PC.  A previous binary snapshot of winGRASS 7 (about a month old) was also working fine, but I uninstalled it to install the most recent version.

I appreciate any ideas you have on what might be going wrong.

Thank you,

This message has been scanned for malware by Websense. www.websense.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20130513/87b4f8ba/attachment-0001.html>

More information about the grass-user mailing list