[GRASS-user] v.in.geonames not importing txt file in GRASS 7.0.0beta3 Windows

Markus Neteler neteler at osgeo.org
Tue Oct 14 13:29:18 PDT 2014

On Fri, Oct 10, 2014 at 11:53 AM, RichardCooper <richtcooper at hotmail.com> wrote:
> Hi,
> I'm getting the following error on attempting to import geonames into GRASS
> 7.0.0beta3 on Windows7.
> I've tried to import via the GUI and command console without success.
> However, it does import with GRASS 7svn[57721] on Linux.
> Richard
> (Fri Oct 10 16:47:43 2014)
> v.in.geonames input=C:\Users\rcooper\Desktop\TH.txt output=geonames_th
> Converting 171472 place names...
> cat: =0: No such file or directory
> cat: output=geonames_th: No such file or directory
> cat: y=5: No such file or directory
> cat: input=C:\Users\rcooper\grassdata7/chula_4326/asiapoptha
> i/.tmp/unknown/408.0: No such file or directory
> cat: columns=geonameid integer,name varchar(200),asciiname

I have tried with current 7.0.svn using

and did not face any problems (on Linux). The Python indentation was
probably not right (fixed in SVN) but I think that this won't matter.

I wonder if the internally used separator "|" may cause the issue?
Perhaps the internal v.in.ascii call should simply be done with the
existing tabs?

A Windows user is needed to explore that...


More information about the grass-user mailing list