[GRASS-user] fatal error: 'libintl.h' file not found (OSX)

Michael Barton Michael.Barton at asu.edu
Wed Oct 15 14:05:31 PDT 2014

I’m glad this worked. But I don’t have a 6.4.5 package. The only GRASS 6.x package I have is 6.4.4 stable, the same one that William has. So I wonder what the difference is? I do compile this with internationalization on but otherwise, it is pretty much the same as William.

C. Michael Barton
Director, Center for Social Dynamics & Complexity 
Professor of Anthropology, School of Human Evolution & Social Change
Head, Graduate Faculty in Complex Adaptive Systems Science
Arizona State University

voice:  480-965-6262 (SHESC), 480-965-8130/727-9746 (CSDC)
fax: 480-965-7671 (SHESC),  480-727-0709 (CSDC)
www: http://www.public.asu.edu/~cmbarton, http://csdc.asu.edu

On Oct 15, 2014, at 1:57 PM, Svein Harald Sønderland <snarrald at gmail.com> wrote:

> Hi,
> I upgraded from v6.4.3 to v6.4.4 and used the KyngChaos installer
> package. After having installed all the necessary packages listed on
> that page the error message about libintl.h was no longer appearing.
> Using this version I currently have no problems neither installing nor
> using the addons I need for my work.
> Prior to using KyngChaos installer package I tried v6.4.5-svn from
> Michael Barton, but in many cases the layers did not show anything
> except for blank layers. The rasters could be selected, but nothing
> appeared on screen. Due to this I quickly jumped over to the KyngChaos
> package, and it luckily worked better (for me).
> Thank you all for your helpful replies, as of now everything seemingly
> works as it should.
> -- 
> Best wishes,
> Svein Harald Sønderland
> On Wed, Oct 15, 2014 at 3:43 PM, William Kyngesburye
> <woklist at kyngchaos.com> wrote:
>> Right, so we're back to the problem, if libintl.h is bundled in the GRASS app include dir, why isn't it found?  I just looked, yes it's there, in the right place, it should work.
>> Svein, is there more before the error?  I'm looking for a line that starts with 'gcc' or 'clang'.
>> On Oct 15, 2014, at 1:08 AM, Markus Neteler <neteler at osgeo.org> wrote:
>>> On Wed, Oct 15, 2014 at 1:57 AM, Michael Barton <Michael.Barton at asu.edu> wrote:
>>>> I do bundle it in my GRASS binaries.
>>>> My point is that there is no functional reason that internationalization (which is otherwise optional in configuration for GRASS) should be needed to compile r.stream. extract.
>>> But don't you compile with --with-nls support? Then it is needed as it
>>> is for most other commands which come with gettext enabled messages.
>>>>>> On Oct 12, 2014, at 3:23 PM, Svein Harald Sønderland <snarrald at gmail.com> wrote:
>>>>>>> Anyone know how to get the r.stream addons to work on mac??
>>>>>>> When trying to install I get this error:
>>>>>>> /Applications/GRASS/GRASS-6.4.app/Contents/MacOS/include/grass/glocale.h:9:10:
>>>>>>> fatal error: 'libintl.h' file not found
>>>>>>> #include <libintl.h>
>> -----
>> William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>
>> http://www.kyngchaos.com/
>> "Those people who most want to rule people are, ipso-facto, those least suited to do it."
>> - A rule of the universe, from the HitchHiker's Guide to the Galaxy

More information about the grass-user mailing list