[GRASS-user] r.drain stops after short segment

Charlie Shobe Charles.Shobe at Colorado.EDU
Tue Oct 28 12:12:38 PDT 2014

Thanks to Markus and Ivan for the help-- I'll answer this on the forum in
case others have the same problem in the future.

For the record, I am using GRASS 6.4.4 on Mac OS 10.9.5.

The problem was that though I ran r.fill.dir once, there were still sinks
in my DEM. After running r.fill.dir 5 total times, I removed all of the
sinks in the DEM and r.drain worked well.

Thanks for indulging a new user!


On Tue, Oct 28, 2014 at 11:52 AM, Ivan Marchesini <ivan.marchesini at gmail.com
> wrote:

> Hi,
> could be that the dtm is not really/completelly filled. Please try to
> verify the elevations of the dtm cells surrounding the one where the drain
> stops.
> Best
> On 28 Oct 2014 17:19, "cmshobe" <charles.shobe at colorado.edu> wrote:
>> Hi all,
>> I am using r.drain with an elevation raster as input. I filled the
>> elevation
>> raster using r.fill.dir. When I run r.drain, it only creates a short path
>> segment before finishing the analysis, even though it hasn't come close to
>> the region border. There should not be any sinks in my elevation raster
>> because I filled it. Does anyone have any experience with this problem?
>> Thanks!
>> Charlie
>> --
>> View this message in context:
>> http://osgeo-org.1560.x6.nabble.com/r-drain-stops-after-short-segment-tp5170003.html
>> Sent from the Grass - Users mailing list archive at Nabble.com.
>> _______________________________________________
>> grass-user mailing list
>> grass-user at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/grass-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20141028/65510b80/attachment.html>

More information about the grass-user mailing list