[GRASS-user] Error trying to compile grass 7 w/libLAS Debian Jessie

César Augusto Ramírez Franco caesarivs at gmail.com
Wed Jun 24 19:30:23 PDT 2015

​Hello Vaclav, thanks for your quick reply​

> What
>     which liblas-config
> says?

​It's the same for me​:

$ which liblas-config

For me on Ubuntu 15.04 it says /usr/bin/liblas-config. So it should work.
> Although I explicitly call
> ​​
>     --with-liblas-config=/usr/bin/liblas-config
> but it is probably not necessary.

​I tried explicitly calling the path to no avail, I'm still getting the
same error :/

Maybe it has something to do with the CFLAGS I'm using? Or something else
on my ./configure stack?

I'm based off the one at the wiki:

On the ticket I found it says: "Adding the LIBLAS_INC to CFLAGS solved this"

How do I do that?

I also tried the 7.0.1RC1 and got the same error, so I'm kind of sure
somethin on my ./configure stack is wrong, here's the one I'm using:

CFLAGS="-g -Wall -Werror-implicit-function-declaration -fno-common -Wextra
-Wunused" \
CXXFLAGS="-g -Wall"  \
./configure \
   --prefix=/usr/local \
   --with-gdal \
   --with-proj --with-proj-share=/usr/share \
   --with-glw --with-nls --with-readline \
   --with-cxx --enable-largefile \
   --with-freetype --with-freetype-includes=/usr/include/freetype2 \
   --with-sqlite --with-cairo --with-python=/usr/bin/python-config \
   --with-wxwidgets --with-geos --with-blas \
   --with-lapack-includes=/usr/lib/lapack --with-liblas=yes \
   --with-netcdf=/usr/bin/nc-config --with-odbc=yes \
   --with-openmp=yes --with-pthread=yes --with-postgres=yes \
   --with-postgres-includes=/usr/include/postgresql \
   --with-postgres-libs=/usr/lib/postgresql \
   --with-mysql=yes --with-mysql-includes=/usr/include/mysql \

Thanks again

*César Augusto Ramírez Franco*
Laboratorio de Sistemas Complejos Naturales
Escuela de Geociencias
Facultad de Ciencias
Universidad Nacional de Colombia - Sede Medellín
Teléfono: (57-4) 430 9369 - 300 459 6085
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20150624/a8d91e13/attachment.html>

More information about the grass-user mailing list