[GRASS-user] i.spec.sam error

Jaya Krishnan jayaakrish at gmail.com
Sat Feb 13 16:55:22 PST 2016


HI again Markus,

Sorry to bother you again. But I was thinking of using Spectral Angle
Mapper in RStudio's RSToolbox package as an alternative. So I followed the
steps at the link
https://grasswiki.osgeo.org/wiki/R_statistics/rgrass7#Using_RStudio_in_a_GRASS_GIS_session
but am unable to run RStudio at the GRASS command prompt. The error is
again * 'rstudio' is not recognized as an internal or external
command,operable program or batch file *(attaching error below).
I changed the path in env.bat file in the GRASS folder to include RStudio
and R, but no luck.

Might there be a solution?

Thanks,

Jaya

[image: Inline images 1]



On 13 February 2016 at 13:07, Jaya Krishnan <jayaakrish at gmail.com> wrote:

> Hi Markus,
>
> Thanks very much for the quick response.
>
> Guess I'll wait till the libraries are installed by the WinGRASS
> maintainer. I suppose the reason I can't use i.spectral is the same,
> although it is not an addon.
>
> Would have loved to attend the meet in Italy, but I don't see a chance, as
> I live in Canada. Thank you for adding it to the agenda though.
>
> Best,
>
> Jaya
> ‚ÄčLinkedIn: ‚Äč
> https://ca.linkedin.com/in/jayaakrish
>
> On 13 February 2016 at 12:51, Markus Neteler <neteler at osgeo.org> wrote:
>
>> Hi Jaya,
>>
>> On Sat, Feb 13, 2016 at 8:34 PM, Jaya Krishnan <jayaakrish at gmail.com>
>> wrote:
>> > Hi Markus and Moritz,
>> >
>> > Thanks for replying.
>> > I am working on Windows 7 and using GRASS 7.0.3 on OSGeo4W. I installed
>> > i.spec.sam using g.extension, and tried to run it from the command
>> console,
>> > but get the error 'i.spec.sam' is not recognized as an internal or
>> external
>> > command,operable program or batch file.
>>
>> Yes, in this case you are not (yet) in luck:
>>
>> How to check  that:
>> https://grass.osgeo.org/grass70/manuals/addons/
>> --> Windows log files
>>     --> imagery/i.spec.unmix FAILED
>>
>> Looking at the log file there, you will see
>>  main.c:31:2: error: #error GRASS is not configured with BLAS
>>  main.c:35:2: error: #error GRASS is not configured with LAPACK
>>
>> That means, that the BLAS and LAPACK libraries are not present on the
>> Windows addons build server.
>>
>> I found some here: https://icl.cs.utk.edu/lapack-for-windows/ but our
>> WinGRASS maintainer would need to install that (i.e. find the time and
>> have success with these libs).
>> Coming soon, I hope.
>>
>> By chance we'll meet next week in Italy, I have taken liberty to add
>> it to the agenda:
>>
>> https://grasswiki.osgeo.org/wiki/GRASS_GIS_contributors_meetings_in_San_Michele/February_2016
>>
>> Best
>> Markus
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20160213/4d74e88c/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 24859 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20160213/4d74e88c/attachment-0001.png>


More information about the grass-user mailing list