[GRASS-user] r.mask: no MASK created when using many categories

Anna Petrášová kratochanna at gmail.com
Wed Apr 5 20:06:56 PDT 2017

On Wed, Apr 5, 2017 at 8:22 AM, Mira Kattwinkel
<kattwinkel-mira at uni-landau.de> wrote:
> Dear List,
> I am using r.mask to create a new raster map that only contains certain
> categories given in 'maskcats'. Then, I use r.mapcalc to save the map under
> a new name and (to be on the save side) delete the MASK with r.mask flag
> '-r'. I do this in a loop and it works fine until a case when the number of
> categories to combine is 213 (trail and error lead to 106 as the maximum
> number that works fine). Flag 'verbose' gives the message that a MASK was
> created, but none is there. The problem arises in both cases when I directly
> use Grass or through R using execGrass.

I tried it on landsat raster from NC sample dataset and it worked.
Perhaps you could try to replicate it with this sample dataset?


> Is there a limit in the number of categories that can be passed to r.mask? I
> did not find any hint about that. Additionally, I wonder why there is no
> error message but in the contrary one that tells me that a MASK was created
> even when it failed.
> In case the details are important (or if anybody has a better idea how to
> achieve what I want): I have a raster map of subcatchemts belonging to
> stream segments created with r.stream.basins. For the endpoints of segments,
> I want to combine these subcatchments to a total catchment raster map
> containing all upstream catchments.
> Thanks a lot,
> Mira
> --
> Dr. Mira Kattwinkel
> Quantitative Landscape Ecology
> Institute for Environmental Sciences
> University of Koblenz-Landau
> Fortstraße 7
> 76829 Landau
> Germany
> Phone: + 49 6341 280-31553
> Office: Building I, Room 2.02
> _______________________________________________
> grass-user mailing list
> grass-user at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/grass-user

More information about the grass-user mailing list