[GRASS-user] (Linux) WXGUI not launching command windows in Fluxbox

Tomáš Brunclík brunclik at atlas.cz
Mon Apr 10 01:49:51 PDT 2017

Hello all,
I just encountered strange wxgui behaviour (Linux 64bit, GRASS 7.2.1svn 
r70326 binary snapshot):
When I run it from MATE desktop environment, everything works normally.
When I run it from Fluxbox, wxgui starts, I can select location and 
mapset, the main program starts normally. But then, selecting (almost) 
any interactive command from menu, i.e. v.info or g.region, nothing 
happens. Also, when I try to run the same command without parameters 
from the console within the layer manager window, nothing happens, 
nothing shows in the console log file if I activate it. When I try to 
run the same command from the terminal emulator window running in the 
GRASS session, it normally launches the v.info window. Very few actions 
do open a window from menu, so far I discovered g.gui.gcp, "Add more 
raster or vector maps (Ctrl-Shift-L)" and "Run script" in File menu and 
panel icons working (translation of menu items from Czech).
Selecting a non-interactive menu item, or putting it in the console, 
like g.region -p ( menu "Settings/Region/Show whole region (g.region 
-p)" ), the command works and shows its output in the output pane of the 
console tab.
Can anyone reproduce this? Is it normal, i.e. does the wxgui need some 
service not running in a bare linux window manager, which is running in 
a typical full desktop environment?
Tomas Brunclik

More information about the grass-user mailing list