[GRASS-user] (Linux) WXGUI not launching command windows in Fluxbox

Tomáš Brunclík brunclik at atlas.cz
Wed Apr 12 03:38:02 PDT 2017

thank you for your interest. The GRASS was started using the grass72 
command installed in /usr/local/bin by the binary snapshot installer. I 
see it is not a missing service, since it runs fine in blackbox as 
opposed to fluxbox for me. Since the previous post I upgraded to latest 
GRASS binary snapshot and I did a quick test and renamed my .fluxbox 
folder, so that it started with default configuration of my Linux 
distribution. The problem persists, so it should not be my fluxbox user 
configuration. Perhaps there is something weird with the specific 
version or more probably the Debian 64-bit build used in the package or 
in the linked libraries? Not a question for this list, if so. It is nice 
to hear it is probably not a general problem of running GRASS in 
Fluxbox, though.

If you are further interested, you can look over the fluxbox 
configuration folder compressed here: 
https://www.dropbox.com/s/z33yew7421af564/fluxbox.tgz?dl=0 (default 
configuration of my distro, recreated after renaming the customized 
one). And some details about the package and libraries:

Package: fluxbox
State: installed
Automatically installed: no
Version: 1.3.5-2
Priority: optional
Section: x11
Maintainer: Dmitry E. Oboukhov <unera at debian.org>
Architecture: amd64

The libraries directly used by fluxbox binary:
     linux-vdso.so.1 (0x00007ffc41928000)
     librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f05f80d3000)
     libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007f05f7ecb000)
     libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 
     libfribidi.so.0 => /usr/lib/x86_64-linux-gnu/libfribidi.so.0 
     libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 
     libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 
     libXinerama.so.1 => /usr/lib/x86_64-linux-gnu/libXinerama.so.1 
     libImlib2.so.1 => /usr/lib/x86_64-linux-gnu/libImlib2.so.1 
     libXpm.so.4 => /usr/lib/x86_64-linux-gnu/libXpm.so.4 
     libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 
     libXft.so.2 => /usr/lib/x86_64-linux-gnu/libXft.so.2 
     libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 
     libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 
     libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 
     libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 
     libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f05f5da0000)
     libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 
     libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f05f57de000)
     libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 
     libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f05f53bc000)
     libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f05f51b7000)
     libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 
     libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f05f4d72000)
     libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 
     libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 
     /lib64/ld-linux-x86-64.so.2 (0x00007f05f8301000)
     libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 
     libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 


Huidae Cho napsal(a):
> Tomas,
> I'm running GRASS trunk on pure Fluxbox 1.3.7 x86-64. I cannot 
> replicate this problem by starting "grass -gui". Can you tell me how 
> you started your grass session? Looks like your fluxbox settings? 
> wxGUI doesn't require any special services only running in a full 
> desktop environment.
> Regards,
> Huidae
> On Mon, Apr 10, 2017 at 5:18 AM, Tomáš Brunclík <brunclik at atlas.cz 
> <mailto:brunclik at atlas.cz>> wrote:
>     Update2: Everything works in Blackbox WM, so it is either issue of
>     Fluxbox, or my configuration of it. Still, it would be interesting
>     if some Fluxbox enthusiast would test it. Probably not worth to
>     bother for others..
>     Tomas B.
>     Tomáš Brunclík napsal(a):
>         Update: I just tried with Fluxbox running inside MATE instead
>         of its default Marco window manager, with the same results as
>         running bare Fluxbox. Maybe it is Fluxbox specific? (Fluxbox
>         1.3.5)
>         Tomas B
>         Tomáš Brunclík napsal(a):
>             Hello all,
>             I just encountered strange wxgui behaviour (Linux 64bit,
>             GRASS 7.2.1svn r70326 binary snapshot):
>             When I run it from MATE desktop environment, everything
>             works normally.
>             When I run it from Fluxbox, wxgui starts, I can select
>             location and mapset, the main program starts normally. But
>             then, selecting (almost) any interactive command from
>             menu, i.e. v.info <http://v.info> or g.region, nothing
>             happens. Also, when I try to run the same command without
>             parameters from the console within the layer manager
>             window, nothing happens, nothing shows in the console log
>             file if I activate it. When I try to run the same command
>             from the terminal emulator window running in the GRASS
>             session, it normally launches the v.info <http://v.info>
>             window. Very few actions do open a window from menu, so
>             far I discovered g.gui.gcp, "Add more raster or vector
>             maps (Ctrl-Shift-L)" and "Run script" in File menu and
>             panel icons working (translation of menu items from Czech).
>             Selecting a non-interactive menu item, or putting it in
>             the console, like g.region -p ( menu "Settings/Region/Show
>             whole region (g.region -p)" ), the command works and shows
>             its output in the output pane of the console tab.
>             Can anyone reproduce this? Is it normal, i.e. does the
>             wxgui need some service not running in a bare linux window
>             manager, which is running in a typical full desktop
>             environment?
>             Regards,
>             Tomas Brunclik
>             _______________________________________________
>             grass-user mailing list
>             grass-user at lists.osgeo.org <mailto:grass-user at lists.osgeo.org>
>             https://lists.osgeo.org/mailman/listinfo/grass-user
>             <https://lists.osgeo.org/mailman/listinfo/grass-user>
>         _______________________________________________
>         grass-user mailing list
>         grass-user at lists.osgeo.org <mailto:grass-user at lists.osgeo.org>
>         https://lists.osgeo.org/mailman/listinfo/grass-user
>         <https://lists.osgeo.org/mailman/listinfo/grass-user>
>     _______________________________________________
>     grass-user mailing list
>     grass-user at lists.osgeo.org <mailto:grass-user at lists.osgeo.org>
>     https://lists.osgeo.org/mailman/listinfo/grass-user
>     <https://lists.osgeo.org/mailman/listinfo/grass-user>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20170412/013d5661/attachment.html>

More information about the grass-user mailing list