[GRASS-user] Cannot re-install Grass 7.2

Moritz Lennert mlennert at club.worldonline.be
Fri Feb 16 06:48:27 PST 2018

On 16/02/18 15:38, Mira Kattwinkel wrote:
> I tried this but still get the same error.

Maybe you still have some old packages installed that have been held. 
You could check with 'dpkg -l "*qgis*" | grep ii' to see all packages 
that are installed and have qgis in their name.

Sometimes, when I get stuck in such a cycle, I just uninstall all qgis 
and grass related packages with:

sudo apt-get remove "*qgis*" --purge
sudo apt-get remove "*grass*" --purge

and then reinstall

sudo apt-get install qgis grass


> On 16/02/18 15:20, Moritz Lennert wrote:
>> On 16/02/18 15:11, Moritz Lennert wrote:
>>> On 16/02/18 15:01, Mira Kattwinkel wrote:
>>>> Hi,
>>>> qgis-plugin-grass depends on Grass 7.2, hence when I try to install
>>>> it I
>>>> get the following message:
>>>> mira at mira-mint ~ $ sudo apt-get install qgis-plugin-grass
>>>> Reading package lists... Done
>>>> Building dependency tree
>>>> Reading state information... Done
>>>> Some packages could not be installed. This may mean that you have
>>>> requested an impossible situation or if you are using the unstable
>>>> distribution that some required packages have not yet been created
>>>> or been moved out of Incoming.
>>>> The following information may help to resolve the situation:
>>>> The following packages have unmet dependencies:
>>>>      qgis-plugin-grass : Depends: grass722 but it is not installable
>>>> E: Unable to correct problems, you have held broken packages.
>> But I'm a bit surprised by this. Looking at the ubuntugis-unstable
>> page, I don't see any dependency to qgis-plugin-grass to grass 7.2. On
>> the contrary, it depends on grass-core (>= 7.4.0).
>> Maybe there was just a missing "apt-get update" before trying to
>> install the plugin ?
>> Try again with ubuntugis-unstable, apt-get update, apt-get upgrade and
>> see what happens.
>> Moritz

More information about the grass-user mailing list