[GRASS-user] grass78 on centos7 from coprs/neteler/grass78

Markus Neteler neteler at osgeo.org
Fri Oct 25 04:52:49 PDT 2019

Dear Laura,

On Fri, Oct 25, 2019 at 9:40 AM Laura Poggio <laura.poggio at gmail.com> wrote:
> Dear Markus,
> the main installation worked fine. Thanks a lot!

glad it installs now, at least without the GUI.

> One more question. I installed grass-gui as well withou problems or errors
> When I start GRASS I get the message: ERROR: wxGUI requires wxPython. No module named 'wx'
> I installed wxPython (and its devel) with yum but I think it is not the right version. I tried to installed it within conda environments or using pip3, but the installation is giving errors.
> Before I start to dig into it, I was wondering if there is some quick solution to get the right wxPython?

In GRASS 7.8, we moved to Python 3.
In Fedora, we use python3-wxpython4 to compile wxGUI:
- https://koji.fedoraproject.org/koji/packageinfo?packageID=26351

However, I don't know where to find a corresponding EPEL package:
- https://centos.pkgs.org/7/epel-x86_64/wxPython-
- https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/w/

Does anyone have an idea? Maybe I am missing something.


More information about the grass-user mailing list