[GRASS-web] Installing r.green is not possible

Markus Neteler neteler at osgeo.org
Mon Nov 11 09:46:02 PST 2019

Dear Annemarie,

Which GRASS GIS version do you use, and on which operating system?
I have tried to install it myself, on a Linux system:

GRASS 7.8.2dev (nc_spm_08):~ > g.extension r.green
Fetching <r.green> from GRASS GIS Addons repository (be patient)...
Traceback (most recent call last):
  File "/home/mneteler/tmp/grass7-mneteler-20201/tmpfggv6w9y/r.green/scripts/r.green.hydro.structure",
line 139, in <module>
    from libgreen.checkparameter import check_required_columns, exception2error
ModuleNotFoundError: No module named 'libgreen'
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Html.make:14:
r.green.hydro.structure.tmp.html] Error 1
DeprecationWarning: the imp module is deprecated in favour of
importlib; see the module's documentation for alternative uses
  import imp
/usr/bin/install: cannot stat
No such file or directory
make[2]: *** [/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/include/Make/Script.make:36:
install] Error 1
Updating addons metadata file...
Updating private addons metadata file...
WARNING: No addons metadata available. Addons metadata file not updated.
Installation of <r.green> successfully finished

GRASS 7.8.2dev (nc_spm_08):~ > r.green.
r.green.biomassfor.co2          r.green.biomassfor.recommended
r.green.gshp.theoretical        r.green.hydro.financial
r.green.biomassfor.financial    r.green.biomassfor.technical
r.green.hydro.closest           r.green.hydro.optimal
r.green.biomassfor.impact       r.green.biomassfor.theoretical
r.green.hydro.delplants         r.green.hydro.planning
r.green.biomassfor.legal        r.green.gshp.technical
r.green.hydro.discharge         r.green.hydro.structure

Some issue seems to be there with "libgreen".

Do you see the same error?

Best regards,


On Wed, Nov 6, 2019 at 11:38 AM Annemarie Pfeiffer
<Annemarie.Pfeiffer at umwelt.uni-giessen.de> wrote:
> Dear Sir or Madam,
> as part of my master's thesis I would like to use the tool
> r.green.hydro with all its functions. After I've completed all the
> steps of your detailed online installation guide, Grass-Gis will
> create a field called "Energy." The functions of this field are grayed
> out and can not be executed. After entering the r.green.install -x
> command, you also receive the message that the python libraries
> numexpr and scipy are not available. After I installed these manually,
> the message did not occur anymore, but the functions in "Energy" were
> also not executable and still written in gray.
> Additionally, when you load Grass-GIS into the black console, you see
> the following message:
> Details: Can not find the executable r.green.hydro ....
> r.green.hydro ...: Unable to fetch interface description for command
> 'r.green.hydro ....' "
> Since I would benefit greatly from the use of the tool for my
> explorations, I would be very grateful if you could help me with my
> problem.
> With best regards
> Annemarie Pfeiffer
> Mit freundlichen Grüßen
> Annemarie Pfeiffer
> _______________________________________________
> grass-web mailing list
> grass-web at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/grass-web

Markus Neteler, PhD
https://www.mundialis.de - free data with free software

More information about the grass-web mailing list