[Gvsig_italian] sextante e modeler

Antonio Falciano afalciano a yahoo.it
Ven 16 Apr 2010 03:59:11 PDT


Il 16/04/2010 12.44, Giuliano Ramat ha scritto:
> Il 16/04/2010 11.10, Antonio Falciano ha scritto:
>> Il 14/04/2010 18.12, Giuliano Ramat ha scritto:
>>
>>> Ho appena fatto un modello in sextante con il modeler ma non
>>> riesco ad applicarlo in batch; ovvero non riesco a salvarlo
>>> nell'albero di sextante.
>>>
>> Giuliano, per poter eseguire un modello in modalita' batch e'
>> assolutamente necessario che questo sia presente all'interno di un
>> gruppo del toolbox. Se il salvataggio del modello non va a buon
>> fine, ti consiglio di ripartire da zero: salva il modello come
>> vuoto, poi aggiungi nuovi processi e risalva, verificando ogni
>> volta se e' caricato nel toolbox (e magari eseguendolo in modo da
>> poter verificare la consistenza degli output intermedi). Cosi'
>> facendo, dovresti facilmente isolare il processo che eventualmente
>> causa il malfunzionamento.
>>
>> ciao Antonio
>>
>>
> Ciao Antonio, Il mio problema  infatti quello di non riuscire a
> salvarlo in un gruppo nel toolbox. Il modello funziona
> tranquillamente e, applicato su un singolo file, da i risultati che
> desidero sia come output finali che intermedi.

...quindi riesci ad eseguirlo solo da modeler? Ti conviene ripartire da
zero, salvandolo come modello vuoto. Esci dal modeler e verifica se il
tuo modello (vuoto) e' presente nel gruppo da te scelto. Se presente, lo
riapri nel modeler, definisci il tuo workflow e risalva tutto. Cosi'
dovrebbe essere ok ...si tratta di un bug fastidioso che molto spesso si
ripropone.

> Ho selezionato il nome, il gruppo nel quale vorrei salvarlo nel
> toolbox, salvato (esiste una cartella specifica in cui salvare ed un
> formato diverso da quello .model proposto?), ma poi non mi compare.

I modelli sono salvati di default nella cartella
"es.unex.sextante/sextante_help", laddove sono presenti due modelli di
esempio. Per cambiare il percorso, in modo da poter utilizzare una
propria cartella dei modelli, devi andare nelle impostazioni di SEXTANTE
mediante il pulsante in basso a destra del toolbox. Nella finestra
Settings, scegli l'opzione Folders e definisci il percorso della tua
cartella dei modelli. Questi ultimi sono sempre salvati con estensione
.model, mentre il gruppo di default in cui sono salvati i modelli e' 
"Models".

ciao
Antonio

-- 
Antonio Falciano
http://www.linkedin.com/in/antoniofalciano



More information about the Gvsig_italian mailing list