[Mapbender-users] Problem with tiled image layer

Clemens Beyer cb at corp.at
Wed Jan 10 09:59:28 EST 2007


I am running Mapserver 4.8.3. I wanted to create a mapfile with a large
image. To optimize speed, I tiled the large image into several parts and
created an index shape file with gdaltindex. The index file creation worked
fine but there seems to be a problem with the image paths in the index file
and/or the TILEINDEX file path in the map file and/or the place where I have
to put the index shape file.

Example: All my map files are in the folder /xxx/wms/yyy.
All shape files are in /xxx/wms/yyy/folder1, /xxx/wms/yyy/folder2 and so on.
My image files are in /xxx/wms/yyy/folder3/tiles.

My first question is: In which folder should I put the index shape file?
And my second question is: How do I specify the correct paths in the map
file (absolute or relative path, and if relative, relative to which base
folder?)? Also, does the SHAPEPATH parameter influence the TILEINDEX path
(like it does with the DATA parameter in not-tiled layers)?

I think I have tried all possible combinations but I only got blank images
or the error message "msWMSLoadGetMapParams(): WMS server error. Invalid
layer(s) given in the LAYERS parameter."

An excerpt of the corresponding map file:

  NAME "test"
  GROUP "Group_1"
  TILEINDEX "" <-- What path has to be written in here?
  TILEITEM "location"
   WMS_SRS  "EPSG:4326"
  OFFSITE 239 237 229

Any help is, of course, welcome... :-)

Best regards from Austria,
View this message in context: http://www.nabble.com/Problem-with-tiled-image-layer-tf2952868.html#a8258818
Sent from the mapbender-users mailing list archive at Nabble.com.

More information about the Mapbender_users mailing list