AW: [Mapbender-users] MB 2.5: Error in saveWMC / loadWMC

Schönhammer, Herbert Schoenhammer.Herbert at
Tue Nov 4 05:16:40 EST 2008

Hello Mr. Scholle,

thank you for your reply.

I'm using SLES10 as Server-OS. That's fix, my IT wants this server.

I've tried now FF 3.x, IE7 and now the latest Opera. It's all the same.

But I had just a look in the webserver error_log. I get the following error-message when saving the the wmc:

 PHP Fatal error:  Class 'DOMDocument' not found in /home/mapbender/mapbender_2.5/http/classes/class_wmc.php on line 239

Will a developper or something else have a tipp for further "researches" ?

Herbert Schoenhammer

 -----Ursprüngliche Nachricht-----
Von: mapbender_users-bounces at [mailto:mapbender_users-bounces at] Im Auftrag von Burghardt.Scholle at
Gesendet: Dienstag, 4. November 2008 08:37
An: mapbender_users at
Betreff: AW: [Mapbender-users] MB 2.5: Error in saveWMC / loadWMC

Hello Mr. Schönhammer,

I still have the same problems in a system combination with Ubuntu 8.04 (Server) and the IE6 (Client). With FF or IE7 I don't have any Problems. In a system combination Debian Etch/Lenny (Server) and any Browser I don't have any problems with save/load WMC too. Perhaps you can try another combination to test the behavior of the module mod_savewmc.php. Unfortunately I don't know a solution for the first combination.

Burghardt Scholle
-----Ursprüngliche Nachricht-----
Von: mapbender_users-bounces at [mailto:mapbender_users-bounces at]Im Auftrag von Schönhammer, Herbert
Gesendet: Dienstag, 4. November 2008 08:16
An: mapbender_users at
Betreff: [Mapbender-users] MB 2.5: Error in saveWMC / loadWMC

Hi list,

I want to generate a WMC-Document with MB 2.5 using the module mod_savewmc.php.

Clicking the button "Save workspace as Web Map Context Document" I am asked for the name of the workspace.

And that was all.

The wmc-document ist not offered using module mod_loadwmc.php. MapBender does not create an entry in mb_error_logs.

I don't find any record in the table mb_user_wmc or any file on the server or an my client.

I have tried all combinations with the var saveInSession:

- the var was set / unset
- the var was filled with the values 0/1
- the var was filled with the values true/false

The behaviour is reproducable with the shipped guis gui1 and gui2.

Where is the problem ?

Has anybody a solution for me ?

Schönhammer Herbert

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Mapbender_users mailing list