[Mapbender-users] Mapbender (2.7.4): Digitizer functionalities

Armin Retterath armin.retterath at lvermgeo.rlp.de
Wed Feb 3 02:34:12 PST 2016


hi lukas,

do you have an online access to your server or a teamviewer installed?
i think we have to debug your installation a little bit. the first thing 
will be to read the mapbender log file while opening the list of 
wfs-configurations.
the logfile is in mapbender/log/ ...
it will be good to open a terminal and do following

tail -f "pathtoyourmapbender"/mapbender/log/mb_error_2016_02_03.log

when no error occurs, it will be good to enable the php error log 
handling in /etc/php5/apache2/php.ini:

following directives should be set somewhere in this file

error_reporting = E_ALL

log_errors = On

error_log = /tmp/php_errors.log

after set this, restart apache2 and open a new terminal at which you do:
tail -f /tmp/php_errors.log

those both terminals will give all needed error messages

if you have no possibility for remote access - please do the logging and 
give back the results messages of both terminals (when trying to access 
the wfs-configuration list in the frontend) to the mailing list.

best regards

armin

On 03.02.2016 11:02, lukas.bollack wrote:
> Hi Armin
>
> I settled for the solution of changing the data type in my postgis database.
> After that, I needed to go trough the whole process in geoserver again, then
> loading the wfs in mapbender and configuring it. I encountered some issues
> then, causing me to play around with the wfs configuration. Then something
> weird happened: When I saved a new wfs configuration I got the usual dialog
> box telling me "The WFS configuration has been inserted into the database.
> Go to 'Assign WFS conf to application' and assign the new conf to an
> application." So far so good, but when I tried to assign the wfs
> configuration to a GUI, the configuration I just created did not show up in
> the list. When I checked under "edit existing wfs configuration" it didn't
> show up either. I thought I maybe did something wrong before and tried to do
> the whole wfs configuration again - but it didn't show in the lists
> afterwards too! I then tried making wfs configurations for other wfs
> services, thinking maybe it has something to do with this particular service
> - didn't work either! The weird thing is, when I delete my loaded wfs
> alltogether "delete wfs" I can see in the list: "List of dependend wfs_conf:
> " that new wfs configurations have indeed been created!
>
> This all seems very weird to me. Have I somehow destroyed my mapbender
> installation? Is there something wrong with it that allows only a certain
> numbers of wfs configurations to be created?
>
> Can you help me out? I'm on a loss here.
>
> Regards
> Lukas
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/Mapbender-2-7-4-Digitizer-functionalities-tp5246772p5248618.html
> Sent from the mapbender-users mailing list archive at Nabble.com.
> _______________________________________________
> Mapbender_users mailing list
> Mapbender_users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/mapbender_users


-- 
Zentrale Stelle Geodateninfrastruktur
Rheinland-Pfalz
LVermGeo-RP

Von-Kuhl-Stra├če 49
56070 Koblenz

0261/492-466
armin.retterath at lvermgeo.rlp.de
http://www.geoportal.rlp.de



More information about the Mapbender_users mailing list