[mapguide-users] SDF & Postgres Join problem

Bogdan Modzelewski Bogdan.Modzelewski at procad.pl
Mon Jul 31 01:45:46 EDT 2006

Hello again,
> This is similar to problems users were having with other kinds of joins.  My guess is that you'll have to wait for the 1.0.1 release for this to be fixed.
> Jason 
So, we have a new version 1.0.1, but a bug is still there. After 
installing MapGuide 1.0.1 and MapGuide Studio 2007 situation haven't 
changed at all.
Does anybody encounter such a thing? Is there any fix for it? Or maybe 
I'm doing something wrong?

Best Regards,

Bogdan Modzelewski
> Hello,
> At first I'd like to sorry for my bad english, but I'm not native speaker.
> I'm new to GIS (and MapGuide in particular) and after 2 days of software
>   learning I've encountered a serious problem (at least for me) - SDF &
> PostgreSQL data joining.
> I'm working with a simple test project in MapGuide Studio Preview. I've
> just imported small SDF file with a few polygons, created layer and
> selected that SDF as a feature source. Everything goes well by this
> point - data is drawed on a map and I can select individual polygons.
> But then I've tried connection with database for automatic labeling and
> tool tips. So, I've created PG connection data and then edited SDF
> feature source to join with PG database by a key. Then I've gone to
> layer edit, selected "PGconnection" as a feature class, Data as a
> geometry (because I'd like to draw geometry from SDF and use DB only for
> labeling). Then I've selected DB properties I'd like to display, set
> Feature label and start a map. At first it looked like it worked as I'd
> want to - polygons were drawed and labels from DB were at correct
> position. But there is a problem also - polygons are not selectable
> anymore :-( Tooltiping also does not working. Of course map option:
> "Features on layer can be selected" for that layer is checked on.
> When I change Feature Class to SDF polygon selecting works again, but
> I've no access to database data, so labeling doesn't work.
> So, what can I do to correct this problem?
> Now I've made a simple workaround - I've created a copy of layer: one
> using DB connection and second not. For a layer with DB joining I've set
> a line color the same like a background so features are not displayed,
> but labels are. Second layer draws just a features (selectable). But
> it's not a solution, for example tool tips are still not working.
> Best Regards,
> Bogdan Modzelewski
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at mapguide.osgeo.org
> For additional commands, e-mail: users-help at mapguide.osgeo.org

More information about the Mapguide-users mailing list