[mapguide-users] Using X,Y from Oracle

Andrew DeMerchant andrew.demerchant at gemtec.ca
Mon Dec 10 10:57:59 EST 2007

I have no experience with Oracle, but I can tell you that in order to 
produce points from x and y data using the ODBC FDO, you need to have 
the x and y fields as doubles, rather than single or integers. You also 
can't have any spaces in the names of ANY fields in tables you're 
using....same goes for table names. Using that method, I can get my 
points to show up fine - using either Access or SQL Server (both via OBDC).


Brad Nesom wrote:
> I haven't seen the new MG's capability to produce points. I know that it was
> a capability in MG6.5. I'm sure someone else will have the answer.
> Brad
> -----Original Message-----
> From: mapguide-users-bounces at lists.osgeo.org
> [mailto:mapguide-users-bounces at lists.osgeo.org] On Behalf Of Kenneth,
> Sent: Monday, December 10, 2007 8:37 AM
> To: MapGuide Users Mail List
> Subject: [mapguide-users] Using X,Y from Oracle
> I have tried to produce points from an Oracle database with only x and y 
> data, no SDO geometry.
> Using King.Oracle these tables do not appear, using the Autodesk 
> provider shows these, but does not allow for mapping with X/Y.
> I then tried to load the Oracle as an ODBC connection.
> After waiting approximately 10 minutes after pressing save, the 
> FeatureSource is saved.
> After this, there are no tables listed in the FeatureSource.
> Can I fix this somehow, or is it better to convert the columns to SDO?

	*Andrew DeMerchant*
*Computer Technologist*
ph.1-877-2GEMTEC x.163
fax 506-453-9470

/GEMTEC Limited <http://www.gemtec.ca>
/191 Doak Road
Fredericton, NB, Canada
E3C 2E6

-------------- next part --------------
Skipped content of type multipart/related

More information about the mapguide-users mailing list