[mapguide-users] Fusion raise AJAX Error, Was: Repository or server error

Kenneth Skovhede, GEOGRAF A/S ks at geograf.dk
Fri Feb 6 03:14:38 EST 2009

AFAIK, the Fusion error is in javascript, and thus no log entry is created.

I don't know enough about Fusion to determine what may have caused the 

Regards, Kenneth Skovhede, GEOGRAF A/S

Rodolfo Moreno skrev:
> Thanks Kenneth, I was a silly I forgot to review the log file.
> this is the error in the log file.
> Error: An exception occurred in FDO component.
>         RDBMS: No current open database.  
> The error is being raised by feature sources with feature joins to SQL 2008
> (my trial version has expired).
> Describing the problem:
> - Municipalities.FeatureSource has 2 featsources: 
> - Municipalities and MunicipalitiesExtension (It has featurejoins). 
> - Layer1 uses Municipalities (not MunicipalitiesExtension)
> - Layer1 is used in Map1, then Map1 raise the RDBMS error.
> I thought that only in the case that MunicipalitiesExtension is used the
> error would be raised (although I guess that it should be like I was
> thought)
> I guess that it solved my problem, However I don't how why some of my maps
> don't work well, even if these are not using layers with feature joins. For
> example before that the expiration date of my SQL, these maps worked good in
> both IE7 and FF2, and now these maps only are work good in FF2 and not in
> IE7. 
> It's happennig with Fusion 1.0.6 (raise AJAX ERROR) and in the mapguide log
> any error is registered. the ajax viewer is working good in both browsers.
> I am really confused, could the SQL expiration has generated the FUSION
> error?
> Regards,
> Kenneth Skovhede, GEOGRAF A/S wrote:
>> What does the error log state:
>> C:\Program Files\MapGuideOpenSource2.0\Server\Logs\Error.log
>> If you can create a MapGuide Package, you can do this:
>> 1. Create MapGuide Package
>> 2. Move the package outside the install dir.
>> 3. Uninstall MapGuide
>> 4. Delete the installation folder
>> 5. Re-install MapGuide
>> 6. Restore the package
>> That should clear any corruption in the repository.
>> I doubt that the repository is the problem though.
>> Regards, Kenneth Skovhede, GEOGRAF A/S
>> Rodolfo Moreno skrev:
>>> Hi all, 
>>> I am having an odd issue.
>>> the problem consists in that the server doesn't send the maps how if
>>> these
>>> did not exist, however when I access to my repository by Maestro or
>>> Studio2009 I can see and edit all the resources of my repository.
>>> the events before that the server or repository started to fail are:
>>> - I was editing my resources using mapguide maestro and mapguide studio
>>> 2009
>>> at the same time.
>>> - My SQL 2008 trial version has expired today (some of my datasources are
>>> stored there). But I have tested another map that doesn't use data from
>>> SQL
>>> and the application doesn't work.
>>> current efects:
>>> - the majority of the times the applications(using these resources) don't
>>> work but sometimes these work. (very odd).
>>> I have restarted the server twice and the error keep on. I guees that for
>>> some reason the repository has been corrupted. So I was looking for a
>>> tool
>>> that allows to repair the repository in REPOSITORYADMIN directory without
>>> successful, becuase the tools within of that directory are for restoring. 
>>> or maybe it to be a server error?
>>> any help will be appreciated,
>>> -----
>>> Rodolfo Moreno
>>> CivilEng
>> _______________________________________________
>> mapguide-users mailing list
>> mapguide-users at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/mapguide-users
> -----
> Rodolfo Moreno
> CivilEng
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapguide-users/attachments/20090206/4743d727/attachment.html

More information about the mapguide-users mailing list