[mapguide-users] Re: Join Problem

_Jon_ jrizzo at Langan.com
Fri Apr 23 10:26:51 EDT 2010

Okay, this is still not right.  I started over by manually re-building my
repository from scratch.  I manually re-created the database connections and
my load procedures, and loaded all of my SDF files into the Library.  I went
through and I defined the joins on a few of them.  However, when I create a
layer, the joins are still not working properly.  They are behaving like
inner joins, even though they are configured as left outer joins.  So, I
went back in to the feature source that was giving me problems, tickled a
few of the settings, and lo-and behold, it gave me the same error as before
when I try to save!  This is not a data migration issue - it has to be
something else.  It has something to do with the interaction between the
layer and the feature resource.  I can open any of the sdf files and save
them UNTIL I create a themed layer using that resource.  Once I create a
layer, the feature source becomes "broken", even if I point the layer to a
different feature source.  Interestingly, Maestro does not report a problem
with the resource.

I guess my site will have to remain in 1.1 for the foreseeable future. 


View this message in context: http://osgeo-org.1803224.n2.nabble.com/Join-Problem-tp4946935p4950793.html
Sent from the MapGuide Users mailing list archive at Nabble.com.

More information about the mapguide-users mailing list