[mapguide-users] Re: Join Problem

Jason Birch jason at jasonbirch.com
Fri Apr 23 15:29:18 EDT 2010

Does this look like your left join problem?


I've asked on the -internals list whether the patch for this has been
submitted and will be in the 2.2 release.

Are you seeing any relevant errors in the MapGuide error log?  After you get
the error, if you restart the MapGuide service and re-connect, can you still
not delete the underlying feature source?

I don't recall seeing any prior reports of this behaviour, so it's likely
that you'll be stuck on 1.1 indefinitely unless you file a Trac ticket that
allows a developer to quickly and easily reproduce the problem.  It may also
be helpful to confirm that this is a generic MapGuide problem and not a
Studio problem by going through the process from start to finish using

Notes on how to file a ticket are available here; might want to search first
to see if there is anything that looks similar, but I couldn't find any with
a quick search:


Re: validator, Maestro has the ability to right-click on any resource and
validate it and its dependencies.  It quickly finds things like layers that
have had their feature sources moved out from under them, mismatched
coordinate system definitions, etc.


On 23 April 2010 07:26, _Jon_ wrote:

> Okay, this is still not right.  I started over by manually re-building my
> repository from scratch.  I manually re-created the database connections
> and
> my load procedures, and loaded all of my SDF files into the Library.  I
> went
> through and I defined the joins on a few of them.  However, when I create a
> layer, the joins are still not working properly.  They are behaving like
> inner joins, even though they are configured as left outer joins.  So, I
> went back in to the feature source that was giving me problems, tickled a
> few of the settings, and lo-and behold, it gave me the same error as before
> when I try to save!  This is not a data migration issue - it has to be
> something else.  It has something to do with the interaction between the
> layer and the feature resource.  I can open any of the sdf files and save
> them UNTIL I create a themed layer using that resource.  Once I create a
> layer, the feature source becomes "broken", even if I point the layer to a
> different feature source.  Interestingly, Maestro does not report a problem
> with the resource.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapguide-users/attachments/20100423/a4f397d2/attachment.html

More information about the mapguide-users mailing list