R: [mapguide-users] gdFontCacheSetup

Bracco Stefano Stefano.Bracco at eurac.edu
Wed Jan 6 12:45:17 EST 2010

If I'm not wrong, the problem is due to the Autodesk SDK Libraries which have not be compiled correctly (or you are using an incorrect version, or a 64bit OS which is not supported). 
If you search in the source for that function, and you search for Makefile, you will see in the code that part of the code is not compiled in special occasions. I think you are using an old version, changing the library with a most recent one, will do the trick. I know it is painful, I lost 1 day searching for the solution when I focused on the right one and I was able to compile.

Let me know.


-----Messaggio originale-----
Da: mapguide-users-bounces at lists.osgeo.org per conto di Randall Read
Inviato: mar 05/01/2010 23.51
A: mapguide-users at lists.osgeo.org
Oggetto: [mapguide-users] gdFontCacheSetup
I am trying to compile Mapguide on RedHat EL 5.4, and am stuck on an error that I have seen in a number of places. However, I am unable to find a solution that works.

I'm new to Mapguide, so I may be making a newbie mistake, but I've searched everywhere for an answer, and have spent a couple of weeks trying out various things.

I have tried compiling 2.0.2 and 2.1.0, along with fdo3.3.0 and fdo3.4.0 respectively. Following the instructions, I get fdo compiled without any problems (seemingly), I get the apache, tomcat, php compiled and installed fine, the build_oem works, configure, but make is failing every time at the same point, no matter the version.

It gets to compiling '/Server/src/Core' and fails with the following:

/usr/bin/ld: warning: libxerces-c.so.27, needed by /home/read/mg/MgDev/Server/src/Services/Drawing/.libs/libMgServerDrawingService.so, may conflict with libxerces-c.so.25
/home/read/mg/MgDev/Common/Renderers/.libs/libMgRenderers.so: undefined reference to `gdFontCacheSetup'
/home/read/mg/MgDev/Common/Renderers/.libs/libMgRenderers.so: undefined reference to `gdFontCacheShutdown'

As far as I can tell, libxerces-c is not the problem, that's just a warning, but the problem is with with gd. I've found places where people have said that getting the latest version of gd (gd2.0.36RC1) worked for them, but I simply cannot get it working.

Any help here would be really appreciated, as the research area at the university I am working for is looking at this package, and I'm setting up a development/test server.

Thanks for any help.

See what's on at the movies in your area. Find out now: http://au.movies.yahoo.com/session-times/
mapguide-users mailing list
mapguide-users at lists.osgeo.org

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/ms-tnef
Size: 4017 bytes
Desc: not available
Url : http://lists.osgeo.org/pipermail/mapguide-users/attachments/20100106/a11ce21e/attachment.bin

More information about the mapguide-users mailing list