[mapguide-users] gdFontCacheSetup

Randall Read randallread at yahoo.com.au
Tue Jan 5 17:51:27 EST 2010

I am trying to compile Mapguide on RedHat EL 5.4, and am stuck on an error that I have seen in a number of places. However, I am unable to find a solution that works.

I'm new to Mapguide, so I may be making a newbie mistake, but I've searched everywhere for an answer, and have spent a couple of weeks trying out various things.

I have tried compiling 2.0.2 and 2.1.0, along with fdo3.3.0 and fdo3.4.0 respectively. Following the instructions, I get fdo compiled without any problems (seemingly), I get the apache, tomcat, php compiled and installed fine, the build_oem works, configure, but make is failing every time at the same point, no matter the version.

It gets to compiling '/Server/src/Core' and fails with the following:

/usr/bin/ld: warning: libxerces-c.so.27, needed by /home/read/mg/MgDev/Server/src/Services/Drawing/.libs/libMgServerDrawingService.so, may conflict with libxerces-c.so.25
/home/read/mg/MgDev/Common/Renderers/.libs/libMgRenderers.so: undefined reference to `gdFontCacheSetup'
/home/read/mg/MgDev/Common/Renderers/.libs/libMgRenderers.so: undefined reference to `gdFontCacheShutdown'

As far as I can tell, libxerces-c is not the problem, that's just a warning, but the problem is with with gd. I've found places where people have said that getting the latest version of gd (gd2.0.36RC1) worked for them, but I simply cannot get it working.

Any help here would be really appreciated, as the research area at the university I am working for is looking at this package, and I'm setting up a development/test server.

Thanks for any help.

See what's on at the movies in your area. Find out now: http://au.movies.yahoo.com/session-times/

More information about the mapguide-users mailing list