[mapguide-users] RE: Compile Error: An attempt was made to load a program with an incorrect format.

airfiol jllj3 at hotmail.com
Fri Mar 25 09:16:25 EDT 2011

No but I was able to get the same error a different way which may provide a
clue. I am able to open the sample web site using the Maestro preview and
also by pasting the Maestro generated URL (which includes a session id, into
the address field. So I know MapGuide is running and the web site works. I
just need to know how to step through the code in debug mode.

After installing MapGuide 2.2 RC4 ( the new installer works very well btw),
I attempted to open the top level mapguide web site using Visual Studio.
When I run in debug mode, I get the following error:

Error	1	It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level.  This error
can be caused by a virtual directory not being configured as an application
in IIS.	C:\Program Files\OSGeo\MapGuide\Web\www\mapviewernet\Web.config	41	

When I to opened the web site mapviewerajax in Visual Studio and attempted
to run in debug mode i get the same error as before.

Error	1	Could not load file or assembly 'MapGuideDotNetApi' or one of its
dependencies. An attempt was made to load a program with an incorrect

View this message in context: http://osgeo-org.1803224.n2.nabble.com/Compile-Error-An-attempt-was-made-to-load-a-program-with-an-incorrect-format-tp6153978p6207641.html
Sent from the MapGuide Users mailing list archive at Nabble.com.

More information about the mapguide-users mailing list