[MapProxy] EPSG:4326 requests from a Tile Source

Oliver Tonnhofer olt at omniscale.de
Tue Dec 14 10:15:45 EST 2010

On 14.12.2010, at 11:34, Jason Lee wrote:
> I think I am having issues with running MapProxy in a Windows environment. Last night, I decided to install and set up a Linux Virtual Machine (Ubuntu) and then proceeded to install and run MapProxy with the same mapproxy.yaml settings, and everything worked just fine (as you already checked and confirmed Oliver).


> Just wonder if anybody else has had similar problems with MapProxy in Windows, particularly using a Tiles source. Maybe it is something to do with conflicts in Windows environment variables or a missing component (I already installed pyproj) or something.

Yes, I had the same issues. I tested MapProxy 0.9.x on Windows today and it seams that the reprojection with pyproj does not work, it just hangs. It works with MapProxy 0.8.5, though. I tried to trace the bug, but I didn't found it jet. It hangs somewhere inside of pyproj, but only when MapProxy is running, not in the unit tests.

> To answer your question Oliver, the additional localhost:8080 request was also hanging so maybe you are right that the server does not handle concurrency on Windows.

No, that was a false guess. The server works as expected.


Oliver Tonnhofer <olt at omniscale.de>
Omniscale - Dominik Helle, Oliver Tonnhofer GbR
Nadorster Str. 60, 26123 Oldenburg
Tel: +49(0)441/9392774-2 (Fax: 9)

More information about the MapProxy mailing list