[MapProxy] Possible Bug in Cleanup?!

Oliver Tonnhofer olt at omniscale.de
Thu Jan 26 05:27:54 EST 2012

On 26.01.2012, at 11:11, Johannes Weskamm wrote:
> i use a set of 23 predefined resolutions.

Good, that was my only explanation why this error could happen.

> I think the problem is, that the inital seed was done on an area which is smaller than the area i use for the cleanup.
> That explains why tiles cant be found.

No, it does check if the tile is stored, but it gets removed in this case between the check and the metadata (timestamp) loading. Typical race condition. The seed tool might handle some tiles twice for res_factor != 2 and in this error case one process has removed the tile between these calls.

> If the behavior of stopping the process is fixed in 1.3.x, the problem should be solved.

To be clear: I fixed it today, so it will be in 1.3.1 and 1.4.0 or in 1.3.x and default when installing "nightly".


Oliver Tonnhofer    | Omniscale GmbH & Co KG    | http://omniscale.de
http://mapproxy.org | https://bitbucket.org/olt | @oltonn

More information about the MapProxy mailing list