[MapProxy] Tile Locks

Максим Хитрин hitrymax at gmail.com
Thu Aug 1 03:15:14 PDT 2013

Yes, MapProxy runs as ApplicationPoolIdentity which makes a user with an
application pool name. In this case - 'mapproxy'. And so there is an IIS
worker process (w3wp.exe) run under this user, mapproxy.
For the whole mapproxy folder I gave permissions for IIS_IUSRS group.
Before that mapproxy didn't run as it was unable to make log file. I've
tried to give other permissions, it didn't work. I guess it's not because
of permissions, but because of async access.
I've looked in lock files which mapproxy is making. There is a process id
of worker process. So does it mean that it is somehow blocking itself?


2013/8/1 Oliver Tonnhofer <olt at omniscale.de>

> Hi,
> On 30.07.2013, at 13:12, Максим Хитрин wrote:
> > I've got some strange problem while I'm trying to request first 3 zoom
> levels within Mapproxy.
> > So here it is. There is a MapProxy installed on Windows Server 2008 and
> working on IIS+isapi_wsgi. When I access one of my layers through the demo
> page - first 3 zoom levels return blank image and then everything works
> well. And in the log file there are following errors, saying that
> permission is denied (although permissions were set):
> [...]
> > IOError: [Errno 13] Permission denied:
> 'C:\\inetpub\\wwwroot\\mapproxy\\config\\..\\cache_data\\obl_kart\\hydro_cache_EPSG4326\\tile_locks\\750bd8b52916e702d64473cb1c4512f8-4-4-5.lck'
> >
> > If I run that config with development server everthing works well and if
> access tiles for those zome levels, wich were failed to load, then they aso
> will work on IIS.
> Hmm, I'm not a Windows/IIS expert. On Linux it is typical that you run
> server applications as another user then the user you use for
> administration. Are you sure that the user that runs MapProxy in IIS also
> has the same permissions?
> Regards,
> Oliver
> --
> Oliver Tonnhofer    | Omniscale GmbH & Co KG    | http://omniscale.com
> http://mapproxy.org | https://github.com/olt    | @oltonn
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapproxy/attachments/20130801/5d3fe3f3/attachment.html>

More information about the MapProxy mailing list