[MapProxy] New MapProxy 1.5.0 and yaml
A.Pirard.Papou at gmail.com
Thu Mar 14 18:25:43 PDT 2013
I asked for help twice to know how to determine if a python package is
No answer but I finally found out and I can start real work now.
My problem was that, somehow, PyYAML==3.10 was installed out of aptitude
When installing the 1.x.0 DEB, python-yaml-3.09 was installed on top and
played havoc with 3.10.
pip uninstall is undocumented (!), but it did uninstall 3.10, which put
an end to war.
Conclusion: one should never mix two installation systems.
Either mapproxy should install DEBs (they are very strongly managing
conflicts and requirements)
or pip and other installers should install python or other stuff by
constructing temporary DEBs.
Well, now to the 1.5.0 config problem (1.4.0 uses the same config nicely):
mapproxy.service.wmts - WARNING - grid 'global_geodetic_sqrt2' is not
compatible with WMTS, skipping for layer 'osm'
Same message for another layer.
Many Google hits for this message, but none seems to apply.
I fear that if maxproxy
* believes that WMTS is used while it is not
* does not understand the grid used by the cache
it could destroy something and I returned to 1.4.0.
Config (part of):
- name: osm
title: Omniscale OSM WMS - osm.omniscale.net
grids: [GLOBAL_MERCATOR, global_geodetic_sqrt2]
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the MapProxy