[MapProxy] New MapProxy 1.5.0 and yaml

Oliver Tonnhofer olt at omniscale.de
Fri Mar 15 04:59:44 PDT 2013


sorry to hear that you had trouble installing MapProxy, suggestions and patches for the documentation are always welcomed.

On 15.03.2013, at 02:25, A.Pirard.Papou wrote:
> problem #1
> My problem was that, somehow, PyYAML==3.10 was installed out of aptitude control.
> When installing the 1.x.0 DEB, python-yaml-3.09 was installed on top and played havoc with 3.10.
> pip uninstall  is undocumented (!), but it did uninstall 3.10, which put an end to war.
> Conclusion: one should never mix two installation systems.
> Either mapproxy should install DEBs (they are very strongly managing conflicts and requirements)
> or pip and other installers should install python or other stuff by constructing temporary DEBs.

MapProxy itself does not install anything, it's pip. pip is a package manager for Python and you find its documentation here: http://www.pip-installer.org/en/latest/

The MapProxy documentation suggests to install MapProxy and its Python dependencies inside a virtualenv to avoid issues with conflicting isntallations.

> problem #2
> Well, now to the 1.5.0 config problem (1.4.0 uses the same config nicely):
> mapproxy.service.wmts - WARNING - grid 'global_geodetic_sqrt2' is not compatible with WMTS, skipping for layer 'osm'
> Same message for another layer.
> Many Google hits for this message, but none seems to apply.

TMS and WMTS have different tile origins and you can configure grids where you cannot just flip the y-axis. global_geodetic_sqrt2 is such a grid that only works for services with origin south-west/lower-left but not with origin north-west/upper-left (like WMTS). 

I agree that it is a bit unfortunate that the default configuration issues warnings and we will update the base-config with 1.6.

> I fear that if maxproxy
> 	• believes that WMTS is used while it is not

You can disable the wmts service by removing it from the services section.

> 	• does not understand the grid used by the cache
> it could destroy something and I returned to 1.4.0.

No, this layer is then just not available for WMTS.


Oliver Tonnhofer    | Omniscale GmbH & Co KG    | http://omniscale.com
http://mapproxy.org | https://github.com/olt    | @oltonn

More information about the MapProxy mailing list