[mapserver-dev] Drop support for ancient GDAL (GDAL < 1.5.0) ?

Daniel Morissette dmorissette at mapgears.com
Mon Mar 5 10:04:03 EST 2012

On 12-03-03 7:17 AM, Even Rouault wrote:
> Hi,
> There are quite a few places in MapServer code that attempt to support
> building against GDAL<  1.5.0 with various #ifdef. I think this is
> unnecessary, and we could happily drop support for such antiquated GDAL
> versions (for reference: Debian Lenny, the oldstable, ships with GDAL 1.5.2)
> for MapServer 6.2.
> Related ticket and patch : http://trac.osgeo.org/mapserver/ticket/4224

No objection here, but as i just wrote in the ticket, if we do this then 
we should probably also update mapogr.cpp to remove blocks of code for 
version < 1.5.0

Daniel Morissette
Provider of Professional MapServer Support since 2000

More information about the mapserver-dev mailing list