[mapserver-dev] MS RFC 88: Saving MapServer Objects to Strings - Call For Vote

Lime, Steve D (MNIT) Steve.Lime at state.mn.us
Thu Feb 14 09:58:06 PST 2013

There is a method called updateFromString() to go the other way. I'd be fine with convertToString() or something like that. They should kind of mirror each other.

From: mapserver-dev-bounces at lists.osgeo.org [mailto:mapserver-dev-bounces at lists.osgeo.org] On Behalf Of Umberto Nicoletti
Sent: Thursday, February 14, 2013 10:45 AM
To: MapServer Dev Mailing List
Subject: Re: [mapserver-dev] MS RFC 88: Saving MapServer Objects to Strings - Call For Vote


is a predefined method name on all Java objects and while it is common to override it and supply a custom implementation I think mapscript
should leave this last option to the user rather than take it for itself.
I suggest the method names is changed to: toMapFileString
before the RFC is approved


On Thu, Feb 14, 2013 at 5:33 PM, Jeff McKenna <jmckenna at gatewaygeomatics.com<mailto:jmckenna at gatewaygeomatics.com>> wrote:


On 13-02-14 12:14 PM, Tamas Szekeres wrote:
> Dear PSC,
> Not requiring to have a large number of pending RFCs out there and
> getting no significant requests to change the concept, I motion to vote
> on RFC 88 <http://mapserver.org/trunk/development/rfc/ms-rfc-88.html>.
> According to Steve's suggestion I've changed the name of the mapscript
> exposed methods to "toString", as the SWIG bindings C#, Java, Python
> still compile with success when applying this change.
> I hereby add my +1 to the motion.
> Best regards,
> Tamas
mapserver-dev mailing list
mapserver-dev at lists.osgeo.org<mailto:mapserver-dev at lists.osgeo.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapserver-dev/attachments/20130214/dc06bd56/attachment-0001.html>

More information about the mapserver-dev mailing list