[mapserver-dev] Corrupt MapServer Zip outputs

Seth G sethg at geographika.co.uk
Sun Nov 21 03:32:12 PST 2021

Hi all,

Following on from the post at https://lists.osgeo.org/pipermail/mapserver-users/2021-November/082429.html I've been trying to find where the cause of the corrupt zips may be. 

There is a msautotest to create zip files and check against the expected output, however the expected output also seems to be an invalid zip file - I tried on both Windows and Linux.

Even stranger this is both in the main branch (simply download the file with the following URL to test), and also going back in the history to 2016.


I had a working process using shapezips in a 7.6 release of MapServer so its hard to understand what could have changed, MapServer, GDAL, or zip formats themselves?
I'll attempt a Git bisect but if the issue is outside MapServer it won't find an issue. 

If anyone is able to open the zip file successfully please let me know (tried with Ark and unzip on Linux and Windows inbuilt unzip and 7-zip on Windows). Error seems to be "87 extra bytes at beginning or within zip file". 


twitter: @geographika

More information about the MapServer-dev mailing list