[mapserver-dev] Corrupt MapServer Zip outputs

jbo-ads at mailo.com jbo-ads at mailo.com
Sun Nov 21 03:49:00 PST 2021

Hi all,

On MacOS Monterey, /usr/bin/unzip gives:

87 extra bytes at beginning or within zipfile
   (attempting to process anyway)
   inflating: road.dbf
   inflating: road.prj
   inflating: road.shp
   inflating: road.shx

And below is an excerpt of "ogrinfo -al road.shp":

Layer name: road
Geometry: Line String
Feature Count: 1
Extent: (2576803.500000, 399102.187500) - (2589745.500000, 402556.250000)


Le 21/11/2021 à 12:32, Seth G a écrit :
> Hi all,
> Following on from the post at https://lists.osgeo.org/pipermail/mapserver-users/2021-November/082429.html I've been trying to find where the cause of the corrupt zips may be.
> There is a msautotest to create zip files and check against the expected output, however the expected output also seems to be an invalid zip file - I tried on both Windows and Linux.
> Even stranger this is both in the main branch (simply download the file with the following URL to test), and also going back in the history to 2016.
> https://github.com/MapServer/MapServer/blob/main/msautotest/wxs/expected/wfsogr10_shapezip.zip
> I had a working process using shapezips in a 7.6 release of MapServer so its hard to understand what could have changed, MapServer, GDAL, or zip formats themselves?
> I'll attempt a Git bisect but if the issue is outside MapServer it won't find an issue.
> If anyone is able to open the zip file successfully please let me know (tried with Ark and unzip on Linux and Windows inbuilt unzip and 7-zip on Windows). Error seems to be "87 extra bytes at beginning or within zip file".
> Seth
> --
> web:http://geographika.co.uk
> twitter: @geographika
> _______________________________________________
> MapServer-dev mailing list
> MapServer-dev at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/mapserver-dev

More information about the MapServer-dev mailing list