[Mapserver-users] Python MapScript Tests Problems ("segmentation fault")

Sean Gillies sgillies at frii.com
Wed May 19 09:54:35 EDT 2004


The tests of appending new output formats will fail unless you
are linking MapServer and mapscript to GDAL.  This is because we
are attempting to create a new GeoTIFF output format.  Since the
GD formats are already built into MapServer, we can't test adding
a GD format.

If you *are* linking to GDAL and the tests continue to fail, I
would like to hear more.

I see you are using GD 1.8!  You should upgrade to the latest
stable (at least 2.0.15+) immediately to take advantage of newer
features and GD+Freetype bug fixes.


On May 19, 2004, at 6:35 AM, Jan Schüngel wrote:

> Hi Michael
> i use MapServer 4.2beta2 with python 2.3, gdal 1.2.0, gd 1.8.3-2
> at the moment i upgrade debian sarge to get the newest lib files.
> i hope that it will solve my problem.
> If i run the test without the two tests, i get only 1 fail, that shoud 
> be
> and 1 error in testShapeCopy (need 2 Arguments, only 1 given)
> Michael Schulz schrieb:
>> Hi Jan,
>> which version of mapserver are you trying? The latest tests i ran 
>> with python mapscript are of version 4.2beta2 and had no segmentation 
>> faults, only:
>> FAILED (failures=2, errors=1), ERROR: testShapeCopy
>> This is with gd-2.0.21, gdal 1.2.0, python 2.1.3.
>> Cheers, Michael
>> Jan Schüngel schrieb:
>>> Hi,
>>> i have severall problems by testing the Python MapScript.
>>> Installing and working is fine, but during the Tests i get a
>>> "segmentation fault"
>>> in Funktions:
>>> testAppendNewOutputFormat
>>> OutputFormatConstructor
>>> on the Line:
>>> new_format = mapscript.outputFormatObj('GDAL/GTiff', 'gtiff')
>>> i think that the problem is with gdal, but i don't find any solution.

More information about the mapserver-users mailing list