[Mapserver-users] GetFeatureInfo no return data with EPSG:4326

Fiorito Marino M.Fiorito at datasiel.net
Thu May 20 05:23:02 EDT 2004


> We have make an OGC WMS Server with Map Server 4.02.  
> Our information are in shapefile in Gauss-Boaga projection (EPSG=26591).  
> In the Map file to level MAP we are:
> 
> ...
>  METADATA
>   ...  
>   WMS_SRS "EPSG:26591 EPSG:4326" 
>  END
>  ... 
>   PROJECTION 
>    "init=epsg:26591"
>   END
>  ...  
> 
> and at the level of the LAYER (ptcp_ass_ins)
>  ...  
>   DUMP true
>  ... 
>   PROJECTION 
>    "init=epsg:26591"
>   END 
>  ...
>   METADATA
>    ...  
>    WMS_SRS "EPSG:26591 EPSG:4326"
>   END
>  
>   
> Therefore we have verified from a OGC WMS VIEWER with map context 
> SRS:  EPSG:4326 	and 
> Bounding Box:  minx=-180, miny=-90, maxx=180, maxy=90 
> the operation of request type WMS.  
> 
> GetCapabilities and GetMap work correctly instead the GetFeatureInfo do
> not return data.  
> 
> The request is:
> http://my.wms?REQUEST=getFeatureInfo&VERSION=1.1.0&BBOX=9.14583344650206,4
> 4.3110392619385,9.27244334040638,44.3743442088906&SRS=EPSG:4326&HEIGHT=360
> &WIDTH=720&QUERY_LAYERS=ptcp_ass_ins&X=439&Y=126&FEATURE_COUNT=10 
> 
> The result is:
> no data does not return:  
> GetFeatureInfo results:  Search returned not results.  
> 
> The same GetFeatureInfo demand made from a OGC WMS VIEWER with map context
> 
> SRS:  EPSG:26591 
> works correctly and return data.
> 
> The PROJ epsg file contain:  
> # WGS 84 
> < 4326 > +proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs no_defs < > 
> 
> Which can be the problem?  
> Thanks for suggestions
> 
> 
> 
> 
> Marino Fiorito
> DATASIEL S.p.A. (Regione Liguria - Gruppo TelecomItalia Finsiel)
> Via Merano 22 16154 Genova
> m.fiorito at datasiel.net
> tel. 010 5484063
> fax 010 587910
> cell. 3336869811
> 
> 



More information about the mapserver-users mailing list