[Mapserver-users] Configure: Same old error - can't find gd.h or libgd.a/libgd.so

Tyler Mitchell TMitchell at lignum.com
Wed May 26 14:33:03 EDT 2004

You will need gd and gd-devel packages - got those already?
In case you are not aware, you do not need to use cygwin to run mapserver 
on windows.  Unless you have a particular reason for doing so, I would 
suggest that it is a waste of time when windows binaries are readily 
available for download and almost immediate use.


mapserver-users-admin at lists.gis.umn.edu wrote on 05/26/2004 10:46:47 AM:

> Hi All,
> I've looked through the archives and the FAQ and tried the solutions 
> presented, but to no avail.
> I am trying to install Mapserver 4.0.2 on Cygwin (running under Windows 
> 2000).
> Please let me know if there is anything else I should be trying to do - 
> running out of hair to tear out of my head.
> Here is the output from configure.sh when run:
> ... Everything running fine above here ...
> checking for strcasecmp... yes
> checking for strncasecmp... yes
> checking for strdup... yes
> configure: checking whether we should include JPEG support......
> checking for jpeg_read_header in -ljpeg... no
>         libjpeg not found. JPEG support not included, possibly needed 
> GD.
> configure: checking where FreeType 2.x is installed......
>         using libfreetype from -lfreetype -lz
> checking for FT_Init_FreeType in -lfreetype... no
>         using libfreetype -lfreetype -lz from system libs.
> configure: checking where Zlib is installed......
>         using libz from -L/lib -lz
> configure: checking where PNG is installed......
> checking for png_init_io in -lpng... no
>         PNG (libpng) library cannot be found, possibly needed for GD
> configure: checking where libXpm is installed......
> checking for XpmFreeXpmImage in -lXpm... no
>         XPM (libXpm) library cannot be found, possibly needed for GD
> configure: checking where libiconv is installed......
> checking for libiconv_open in -liconv... no
>         libiconv library cannot be found, possibly needed for GD
> configure: checking for GD 2.0.12 or higher......
> checking for gdImageSetAntiAliased in -lgd... no
> configure: error: "Could not find gd.h or libgd.a/libgd.so in 
> Make
> sure GD 2.0.12 or higher is compiled before calling configure."
> I have tried running "./configure --with-gd=/usr/local", as well as with 

> /usr/local/lib (the location of the libgd.a file) and /usr/local/include 

> (the location of the gd.h file).
> I have looked through for duplicates of these files, but cannot find any 

> others residing on the disk.
> --Adam
> _________________________________________________________________
> STOP MORE SPAM with the new MSN 8 and get 2 months FREE* 
> http://join.msn.com/?page=features/junkmail
> _______________________________________________
> Mapserver-users mailing list
> Mapserver-users at lists.gis.umn.edu
> http://lists.gis.umn.edu/mailman/listinfo/mapserver-users

More information about the mapserver-users mailing list