[Mapserver-users] Can't locate object method "TIEHASH"

Agneta Schick schick at sdac.hannover.bgr.de
Fri May 28 05:54:04 EDT 2004

Hello mapserver-users,

I've searched the mail archive and found 2 messages on this topic,
both were, however, unanswered.

So I'll try again...

	MapServer 4.0.1
	solaris 9
	Perl 5.8.3

I want to test an application querying shape files.
My perl mapscript code
  my $res = $layer->getResult(0);
  my $shape=new mapscript::shapeObj($layer->{type});
  my $shape_index = $layer->getShape($shape,-1,$res->{shapeindex});
  my $table = 
is terminated with 
Can't locate object method "TIEHASH" via package "_DBFHandle".

Is this a mapscript problem or is something missing in the installation?

(I tried the same perl script on solaris 8, mapserver 3.6.5, perl 5.6
and got the same error).

Agneta Schick

    Agneta Schick
    Bundesanstalt fuer Geowissenschaften und Rohstoffe
    Federal Institute for Geosciences and Natural Resources
    Stilleweg 2
    D- 30655 Hannover                   Tel.: +49 511 643 3136
    GERMANY                             FAX.: +49 511 643 3663

    schick at sdac.hannover.bgr.de         http://www.seismologie.bgr.de

More information about the mapserver-users mailing list