[osgeo4w-dev] packaging a tad bumpy

Matt Wilkie maphew at gmail.com
Mon Apr 6 04:07:16 EDT 2009

Hello All,

I encountered a number of packaging difficulties with the trivial mys
change (#78) unrelated to the change itself. I'll share them here in
the hopes we might find a way to smooth some of them out.

* http://upload.osgeo.org/cgi-bin/osgeo4w-regen.sh did not update
either setup_test.ini or versions*.html pages. It took about a minute
to run.
 * running regen.sh from login shell updated setup_test.ini but not
the versions*.html pages
 * promote_test.sh from login shell worked (did not try the cgi version).

A few weeks ago I reported that setup.exe cannot unpack the tar.bz2
created by 7zip. Today I can extend that lack of success to also
include gnuwin32's bzip2. Surprisingly I'm pretty sure cygwin's own
bzip2 also doesn't work though I didn't test this last on completely
because I was tired of up/dnloading the same file over and over again.
When I diff'd gnuwin32 and cygwin's output, the files were exactly the

In the end I worked around the problem by uploading the non-working
package to upload.osgeo.org, opening a remote shell on same, and
unpacking & repacking using the tar & bzip2 on that machine.

I found one other report of problems with 7zip and cygwin setup, but
no illumination:



More information about the osgeo4w-dev mailing list