[osgeo4w-dev] Problems re-installing on WinXP 64

Frank Warmerdam warmerdam at pobox.com
Wed Jan 14 12:53:00 EST 2009

Lucena, Ivan wrote:
> Hi there,
> I have several other GDAL environment on that machine so I decided to clean up a little bit and start from scratch the OSGeo4W installation.
> Now I can't get it to work anymore. Nothing. gdal tools, OpenEV and I also tried to install GRASS and QGIS each one of then complain about one 
> dll or another.
> I tried to run the OSGeo4W again installing each one of the missing dll to the resolve those issues but it doesn't work. There is always something 
> wrong or missing. I waste the last two days doing that.
> Does anybody has ever got in to that mess before? Any hint on how to get out of it? Was OSGeo4W installer tested on Win64 before? Is there a 
> better way to uninstall and start from scratch then deleting the folder?
> Thank you so very much for any attempt to help.


I'm rather at a loss as to why this would occur.  The OSGeo4W installer
keeps track of installed packages in the OSGeo4W\etc directory.  So if
you wipe the whole tree it should start with a clean sense of what
what is installed.  The only thing I am aware of the setup program keeping
in the registry (outside the OSGeo4W tree) is the default settings for
where the cache, and install tree are.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the osgeo4w-dev mailing list