[osgeo4w-dev] Re: [Qgis-developer] cannot build qgis with python inside osgeo4w: python isn't detected

G. Allegri giohappy at gmail.com
Mon Mar 30 05:36:47 EDT 2009

Ok, I've solved this problem. I had to fix python manglings, between
my own installs and osgeo4w.

Now I can build almost everything but:

1 -  It misses the important part for me: grass! I've recompiled grass
from trunk and created the .lib files with dumplib, etc. Now they're
located under OSGeo4W/apps/grass/grass-6.5.svn/lib, but thet're named
with 'lib' prefix (i.e. libgrass_arraystats.dll), while the libs
provided with OSGeo4W don't have it (grass_arraystats.dll). Why? Is
this causing grass not to be compiled? The strange is that cmake
doesn't raise errors, but grass folder isn't there (under plugins dir)
as expected...

2 - nmake install exits with error because it can't locate
win_build/vcdeps files. I see thy're set in cmale_install.cmake...
What is that folder?! Where CMAKE_INSTALL_COMPONENT should have been

Thanks for you great help!

2009/3/28 Tim Sutton <lists at linfiniti.com>:
> Hash: SHA1
> Hi
> G. Allegri wrote:
>> I'm on the way to finish my build of qgis_unstable with osgeo4w, but
>> I'm blocked because of python bindings. Even if I set all the
>> requestes tags in cmakesetup (ie
>> PYTHON_EXECUTABLE:FILEPATH=C:/OSGeo4W/bin/python.exe), cmake says it
>> cannot build it. I premit that I've downloaded all the required deps
>> with osgeo4w setup.
>> Cmake can find Python if enable my registry keys about my system
>> Python25. I had disabled them because cmake detected them, and put the
>> paths (like C:\Python25) in the related makefiles. The consequence
>> were errors, because it tried to build the undetected core.pyd,
>> gui.pyd, in that path...
>> So the question is: why cmake shouldn't/couldn't use the paths I set
>> with cmakesetup?
>> Giovanni
>> _______________________________________________
>> Qgis-developer mailing list
>> Qgis-developer at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/qgis-developer
> One other thing to check is that you have run the osgeo shell
> environment bat script before running cmakesetup.
> Regards
> Tim
> - --
> Tim Sutton - QGIS Project Steering Committee Member (Release  Manager)
> ==============================================
> Please do not email me off-list with technical
> support questions. Using the lists will gain
> more exposure for your issues and the knowledge
> surrounding your issue will be shared with all.
> Visit http://linfiniti.com to find out about:
>  * QGIS programming and support services
>  * Mapserver and PostGIS based hosting plans
>  * FOSS Consulting Services
> Skype: timlinux
> Irc: timlinux on #qgis at freenode.net
> ==============================================
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> iEYEARECAAYFAknOE9IACgkQqk07qZdiYjde6QCfcy4N9olT3phNZSrl4t6hhhvF
> Y/4An3D4wQ9nmSAD9NcO3DsG/vClk2zV
> =FGxE

More information about the osgeo4w-dev mailing list