[osgeo4w-dev] mscvr90

Julien Malik julien.malik at c-s.fr
Thu Nov 17 10:22:53 EST 2011


I'm hitting a wall on these (damned!) manifest/CRT issues.

I'm using OSGeo4W as a pool of prebuilt libraries to build/test software 
on top of it.
I'm building with Visual Express 2008 / Win7 , and since some time now, 
I lost my "Debug" build :
* When building the software in Release mode, everything runs OK.
* When building the software in Debug mode, I get an error at runtime 
for all my apps :
    "R6034 An application has made an attempt to load the C runtime 

Glad I found this thread, because downgrading the libtiff package to 
4.0.0dev-90 (which depends on VC71, while the current 4.0.0dev-91 is 
built with VC9) solves the issue : the debug build is usable again.
I have a bunch of msvc*90.dll versions (10 actually !) in my 
Windows/winsxs folder but I have no idea if the one that OSGeo4W msvcrt 
package is supposed to install is actually there.

Going back with the 4.0.0dev-91 version, in Release mode, I found 
something weird : the msvc*90.dll required by libtiff dll are found from 
my CMake installation dir (in my PATH), not from the winsxs folder (saw 
this with dependency walker).
When I remove them from my PATH, dependency walker can't find the 
required msvcr90 and msvcp90 dlls required by libtiff.dll.
But for example xerces-c_3_1.dll is ok and finds its required 
msvcr90.dll from my winsxs folder.
And my own Release executables (linked to gdal and libtiff) find what 
they need too in winsxs.
I tried to manually uninstall/reinstall the vcredist_2008_x86 included 
in the msvcrt 1.0.1-5 osgeo package. No luck on this. I checked the 
windows event log and it says the package installed fine.

Another strange dependency issue with libtiff-4.0.0dev-91 , once I 
removed the cmake-provided msvc9 dll from my PATH :
- tiffinfo won't start (same R6034 error)
- gdalinfo (which depends on libtiff) runs fine !?!?!
In dependency walker, I see that tiffinfo does not find the msvc9 dll, 
like libtiff.dll. But gdalinfo finds it correctly in the Windows/winsxs 

Any idea about what is going on ?
Does tiffinfo from the libtiff-4.0.0dev-91 package runs fine on your 
osgeo4w install ? If yes, where does the msvc9 dll comes from ?
Is there something wrong specifically with the libtiff binaries version 
4.0.0dev-91 (manifest information missing or something along those lines) ?

Does anyone succeed in building and running a software with Visual 2008 
Express in Debug mode, linking to libtiff from the 4.0.0dev-91 package ?

Any idea of thing to check/test/reinstall is warmly welcome, I'm 
definitely lost...

Le 05/09/2011 14:54, Martin Landa a écrit :
> Hi,
> 2011/9/1 Martin Landa<landa.martin at gmail.com>:
> see the answer from grass-dev ML by Markus Metz:
> """
> Same problem here, solved by downgrading libtiff through the osgeo4w
> installer to 4.0.0dev-90 and removing again patched-in msvcr90.dll and
> msvcp90.dll from osgeo4w\bin. libtiff-bin and libtiff-devel seem to be
> ok. Looks like a osgeo4w packaging bug...
> Markus M
> """
> Martin

More information about the osgeo4w-dev mailing list