[osgeo4w-dev] mscvr90

Matt Wilkie matt.wilkie at gov.yk.ca
Thu Nov 17 13:11:48 EST 2011

Hi Julien,

I have libtiff 4.0.0.dev-91 installled on Win7x64, and running tiffinfo 
yields the same R6034 error you mention. Also like you, gdalinfo (GDAL 
1.8.1, released 2011/07/09) has no apparent problems. I don't have 
Visual Express.

Running "dir /b/s c:\msvcr90.dll" found 31 copies of that file on my 
system (see attached).

Changing PATH in the o4w command shell to simply "PATH=c:\o4w_py27\bin", 
changed the tiffinfo error message to  "The program can't start because 
MSVCR90.dll is missing from your computer. Try reinstalling the program 
to fix this problem". Extending path to include an o4w package 
containing msvcr90.dll, e.g. qgis, makes tiffinfo go back to the R6034 
error.  Gdalinfo continues to run fine; maybe this is because gdalinfo 
actually relies on libgeotiff and not libtiff?

>From  the msvcrt-1.0.1-5 o4w package I extracted vc_red.cab from 
vcredist_2008_x86.exe (using 7zip), and then put each kind of dll into 
it's own directory, renamed as expected. So "nosxs_msvcr90.dll" to 
".\vc2008_nosxs\msvcr90.dll" and "msvcr90.dll.30729.*.sp" to 
".\vc2008_30729\msvcr90.dll", etc. I then added each of those 
directories to path in turn (solo, not additive) and ran tiffinfo: R6034 
errors in all cases.

I repeated this with the msvcrt-1.0.1-4 package and got identical results.

I then extracted libtiff-4.0.0dev-91.tar.bz2 into d:\libtiff-dev91, and 
from a command shell with a minimal o4w path (PATH=c:\o4w_py27\bin) ran 
tiffinfo, got R6034.

Repeat with libtiff dev-90: WORKS -- yet there aren't any msvc*90.dll in 
PATH (!)

I deleted PATH altogether: dev-90 tiffinfo complains of missing 
'jpeg_osgeo.dll', and then 'zlib_osgeo.dll'.
I copy those from c:\o4w_py27\bin into d:\libtiff-dev90: tiffinfo works 

So it looks to me like libtiff-dev91 thinks it requires something fomr 
msvcr*.dll, when it actually doesn't, but won't carry on until the 
mistaken assumption is cleared. Or something.

Anyway, cleary libtiff-4.0.0dev-91.tar.bz2 is broken and should be 
replaced or removed from the package repository if it can't be fixed.

I hope something in all this helps!

matt wilkie
Geomatics Analyst
Information Management and Technology
Yukon Department of Environment
10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
867-667-8133 Tel * 867-393-7003 Fax

On 17/11/2011 7:22 AM, Julien Malik wrote:
> Hello,
> I'm hitting a wall on these (damned!) manifest/CRT issues.
> I'm using OSGeo4W as a pool of prebuilt libraries to build/test software
> on top of it.
> I'm building with Visual Express 2008 / Win7 , and since some time now,
> I lost my "Debug" build :
> * When building the software in Release mode, everything runs OK.
> * When building the software in Debug mode, I get an error at runtime
> for all my apps :
>      "R6034 An application has made an attempt to load the C runtime
> incorreclty."
> Glad I found this thread, because downgrading the libtiff package to
> 4.0.0dev-90 (which depends on VC71, while the current 4.0.0dev-91 is
> built with VC9) solves the issue : the debug build is usable again.
> I have a bunch of msvc*90.dll versions (10 actually !) in my
> Windows/winsxs folder but I have no idea if the one that OSGeo4W msvcrt
> package is supposed to install is actually there.
> Going back with the 4.0.0dev-91 version, in Release mode, I found
> something weird : the msvc*90.dll required by libtiff dll are found from
> my CMake installation dir (in my PATH), not from the winsxs folder (saw
> this with dependency walker).
> When I remove them from my PATH, dependency walker can't find the
> required msvcr90 and msvcp90 dlls required by libtiff.dll.
> But for example xerces-c_3_1.dll is ok and finds its required
> msvcr90.dll from my winsxs folder.
> And my own Release executables (linked to gdal and libtiff) find what
> they need too in winsxs.
> I tried to manually uninstall/reinstall the vcredist_2008_x86 included
> in the msvcrt 1.0.1-5 osgeo package. No luck on this. I checked the
> windows event log and it says the package installed fine.
> Another strange dependency issue with libtiff-4.0.0dev-91 , once I
> removed the cmake-provided msvc9 dll from my PATH :
> - tiffinfo won't start (same R6034 error)
> - gdalinfo (which depends on libtiff) runs fine !?!?!
> In dependency walker, I see that tiffinfo does not find the msvc9 dll,
> like libtiff.dll. But gdalinfo finds it correctly in the Windows/winsxs
> folder.
> Any idea about what is going on ?
> Does tiffinfo from the libtiff-4.0.0dev-91 package runs fine on your
> osgeo4w install ? If yes, where does the msvc9 dll comes from ?
> Is there something wrong specifically with the libtiff binaries version
> 4.0.0dev-91 (manifest information missing or something along those lines) ?
> Does anyone succeed in building and running a software with Visual 2008
> Express in Debug mode, linking to libtiff from the 4.0.0dev-91 package ?
> Any idea of thing to check/test/reinstall is warmly welcome, I'm
> definitely lost...
> Julien
> Le 05/09/2011 14:54, Martin Landa a écrit :
>> Hi,
>> 2011/9/1 Martin Landa<landa.martin at gmail.com>:
>> see the answer from grass-dev ML by Markus Metz:
>> """
>> Same problem here, solved by downgrading libtiff through the osgeo4w
>> installer to 4.0.0dev-90 and removing again patched-in msvcr90.dll and
>> msvcp90.dll from osgeo4w\bin. libtiff-bin and libtiff-devel seem to be
>> ok. Looks like a osgeo4w packaging bug...
>> Markus M
>> """
>> Martin
> _______________________________________________
> osgeo4w-dev mailing list
> osgeo4w-dev at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/osgeo4w-dev
> .
-------------- next part --------------
C:\Program Files (x86)\Bazaar\msvcr90.dll
C:\Program Files (x86)\CamStudio 2.6b\msvcr90.dll
C:\Program Files (x86)\Common Files\ArcGIS\bin\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\Common Files\Tom Sawyer Software\8.0.0\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\Explorer\bin\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\redist\amd64\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\redist\x86\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 OSS\msvcr90.dll
C:\Program Files (x86)\OpenSTV\lib\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\OpenSTV\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\TaskCoach\Microsoft.VC90.CRT\msvcr90.dll
C:\Program Files (x86)\Xara\Xara_Designer_Pro_7\ShiftN\msvcr90.dll

C:\Program Files (x86)\Bazaar;
C:\Program Files\TortoiseSVN\bin;
C:\Program Files\TortoiseHg\;

More information about the osgeo4w-dev mailing list