[osgeo4w-dev] findstr in addPath runs forever on windows7

Matt Wilkie matt.wilkie at gov.yk.ca
Fri Jun 29 10:18:03 PDT 2012

Hi Asger,

Thanks for that complete and clear report. We'll see if anyone else can 
reproduce it. At least we have a very simple test case now.

Enjoy you're time off grid :)

matt wilkie
Geomatics Analyst
Information Management and Technology
Yukon Department of Environment
10 Burns Road * Whitehorse, Yukon * Y1A 4Y9
867-667-8133 Tel * 867-393-7003 Fax

On 29-Jun-2012 2:19 AM, Asger Sigurd Skovbo Petersen wrote:
> ( My first message awaits moderation because of attached screendumps. 
> This message is without screendumps which instead can be found at 
> http://imgur.com/a/ij7vl )
> Hi Matt,
> I tried running the script from 
> https://bitbucket.org/maphew/addpath/src/8cde9893daa4/bug_295
> It still hangs on findstr. Please see attached screendump 
> (maphew_bug_295_bat_from_git.png). On the dump you can see that 
> findstr has used 2:27 CPU minutes. This time it didnt crash - I killed 
> it after 13 CPU minutes.
> I tried running
> echo ^"c:\test|findstr /i /r /c:^"^^\"[a-zA-Z]:[\\/][^\\/]"
> This statement also just runs forever. Please see attached 
> findstr_simple_test.png.
> Running
> findstr /i /r /c:^"^^\"[a-zA-Z]:[\\/][^\\/]"
> has exactly the same result as the two above: findstr runs forever at 
> full speed on one core. And it does not allow (or at least react to) 
> user input.
> From this afternoon and three weeks ahead I will be offline. Another 
> problem with regard to this bug is that I will not have access to this 
> exact computer when I get back.What I will have is another computer 
> installed with the exact same image as this one. So in some way I hope 
> that I cannot reproduce the bug by then :-)
> Best regards
> Asger

More information about the osgeo4w-dev mailing list