[osgeo4w-dev] Binary inconpatible GDAL plugin for Oracle

Ivan Lucena ivan.lucena at princeton-ma.us
Wed Feb 27 10:49:30 PST 2013

Hi Jürgen,

I am not a OSGeo4w contributor, so I don't know how things are build. But I remember that at one time, probably 4 years ago, I uploaded the Oracle plugins to GDAL ftp repository (That doesn't exist anymore) and those DLL where used by OSGeo4W, some how, without my acknowledge. That is to me a hint that indicates that the plugins are not build on the same environment as the GDAL tools are.

Anyway, here comes the symptoms:

1 - After installing GDAL latest (1.9.2) with GDAL-Oracle plugins, the OSGeo4W show an error message when it tries to run "gdalinfo --version" at the end of the shell initialization script.

2 - Running gdalinfo or ogrinfo with Oracle driver doesn't work and the errors random, sometimes an error message pops up, sometimes nothing happens, just the prompt comes back without any printing.

3 - QGIS also doesn't work when you try to load vector or raster. You might get a connection sometimes or even get a georaster to display but it crashes when loading geometries.

4 - Everything goes back to normal if I Just do that:

C:\OSGeo4W\bin\gdalplugins\1.9> copy "\Program Files (x86)\GDAL\gdalplugins\gdal_GEOR.dll" .
C:\OSGeo4W\bin\gdalplugins\1.9> copy "\Program Files (x86)\GDAL\gdalplugins\ogr_OCI.dll" .

5 - On that source folder I have GDAL installed from gdal-19-1600.core.msi and gdal-19-1600-oracle.msi. I tried with gdal-19-1500-core.msi and gdal-19-1500-core.msi and got similar problems as with the original OSGeo4W GDAL Oracle plugins.

So it seems like the problem is about VC binary incompatibility. IMHO.

But I understand you point, the problem deserves a good explanation.

One more think. I have users that got QGIS directly from QGIS website and encountered the same problem after installing and trying to use the Oracle plugins. Would that be a coincidence?

If some that knows the building/assembling and installation process in OSgeo4W could help. That would be great.

Best regards,


>  -------Original Message-------
>  From: Jürgen E. Fischer <jef at norbit.de>
>  To: osgeo4w-dev at lists.osgeo.org
>  Subject: Re: [osgeo4w-dev] Binary inconpatible GDAL plugin for Oracle
>  Sent: Feb 27 '13 12:33
>  Hi Ivan,
>  On Wed, 27. Feb 2013 at 12:11:53 -0500, Ivan Lucena wrote:
>  > After updating to the latest distribution of GDAL command line and QGIS from
>  > OSGeo4W users are having problem when the application tries to load the GDAL
>  > plugins related to Oracle.
>  > I tried to replace the plugins libraries ogr_OCI.dll and gdal_GEOR.dll with
>  > the ones provided by www.gisinternals.com/sdk and it seems like the correct
>  > version would be GDAL 1.9.2 compiled with MSVC 2010, that is VC 1600. That
>  > works for GDAL command line and QGIS.
>  Why should those be any better than what it shipped in OSGeo4W already?  The
>  gdal oracle plugin are built with OCI package in OSGeo4W against the GDAL in
>  OSGeo4W.
>  > Should I file a ticket for that?
>  If it clearer than the description above - doesn't tell much about how to
>  reproduce the problem.
>  Jürgen
>  --
>  Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-31
>  Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
>  Software Engineer         D-26506 Norden               http://www.norbit.de
>  committ(ed|ing) to Quantum GIS                         IRC: jef on FreeNode                        
>  --
>  norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
>  Rheinstrasse 13, 26506 Norden
>  GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502
>  _______________________________________________
>  osgeo4w-dev mailing list
>  osgeo4w-dev at lists.osgeo.org
>  http://lists.osgeo.org/mailman/listinfo/osgeo4w-dev

More information about the osgeo4w-dev mailing list