[osgeo4w-dev] QGIS failed to start because QT platform plugin

Pedro Venâncio pedrongvenancio at gmail.com
Thu Aug 20 04:45:06 PDT 2020

Hi Jurgen,

Thanks for the feedback!

The strange thing is that it only happens when starting QGIS thru
qgis-rel-dev-g7.bat or qgis-ltr-dev-g7.bat (with GRASS). And if I change
the line

start "QGIS" /B "%OSGEO4W_ROOT%\bin\qgis-rel-dev-bin-g7.exe" %*
start "QGIS" /B "%OSGEO4W_ROOT%\bin\qgis-rel-dev-bin.exe" %*

it already starts QGIS as expected.

I've also removed all OSGeo4W folder and installed again, but the behaviour
is the same.

Thanks Jurgen!

Best regards,

Jürgen E. Fischer <jef at norbit.de> escreveu no dia quinta, 20/08/2020 à(s)

> Hi Pedro,
> On Wed, 19. Aug 2020 at 10:45:08 +0100, Pedro Venâncio wrote:
> > Today I tried again, to qgis-ltr-dev 3.10.9-1 and qgis-rel-dev 3.14.15-1,
> > but I get the same error message.
> >
> > Is some QT update missing?
> I guess not.  There weren't any recent osgeo4w updates to Qt.  And QGIS is
> apparently working fine for others.
> The platform DLLs are in %OSGEO4W_ROOT%\apps\Qt5\plugins\platforms.  My
> first
> bet would be something fishy in system32 that mask an osgeo4w DLL and check
> with dependency walker.
> Jürgen
> --
> Jürgen E. Fischer           norBIT GmbH             Tel. +49-4931-918175-31
> Dipl.-Inf. (FH)             Rheinstraße 13          Fax. +49-4931-918175-50
> Software Engineer           D-26506 Norden
> https://www.norbit.de
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/osgeo4w-dev/attachments/20200820/70f4b64a/attachment.html>

More information about the osgeo4w-dev mailing list