[Live-demo] 4.0 rc5 build

Alex Mandel tech_dev at wildintellect.com
Tue Jul 27 22:18:28 PDT 2010

This is the revision the disc was built with

What user are you running it as?
The reason that the sudo -u is there is because the scripts run as root
but root does not have access to postgres only user does.

So you could try:
sudo su user
run commands
exit (can you do exit in a script like that?)


On 07/27/2010 10:00 PM, Daniel Kastl wrote:
> Hi Alex,
> Somehow I still have a problem with one part of the pgRouting install script
> (building the sample data).
> The log says (from line 4036):
> create pgrouting database
> add PostGIS functions
> add pgRouting core functions
> add pgRouting TSP functions
> unpack sample data
> Run osm2pgrouting converter (this may take a while)
> host= user=user dbname=pgrouting port=5432
> connection failed
> The database is there, all required PostGIS/pgRouting funtions as well.
> Last week I actually thought I found the reason and removed the initial
> "sudo -u $USER_NAME" (line 120 in install_pgrouting.sh).
> I tested it on the VM and when I run "osm2pgrouting" with "sudo" I get the
> "connection failed" error, when I run it without it works.
> I updated SVN already a few days ago, but could you make sure that
> your install_pgrouting.sh was the latest one and has no "sudo -u $USER_NAME"
> in line 120?
> Daniel
> 2010/7/28 Alex Mandel <tech_dev at wildintellect.com>
>> Much better, but still a few quirks:
>> http://download.osgeo.org/livedvd/4.0-rc5/4.0rc5logs.tar.gz
>> The Help Launcher is nowhere to be seen, the files are there the logs
>> seem ok, maybe the icon shuffle at the end did it in(I looked but didn't
>> see it in any of the folders)? Also Mapbender is still floating on the
>> desktop.
>> FYI looks like something is still making a /usr/local/livedvd-docs
>> folder but all our stuff is in osgeolive-docs, someone want to find and
>> kill that uneeded folder?
>> Firefox homepage reset doesn't work, but that's nothing new, I did it by
>> hand this time. I also added the Geospatial menu from it's file, the cpu
>> monitor and the keyboard switcher so I don't forget to do it on the
>> final builds.
>> I'm still compressing the image to 7z, should be ready in a hour or
>> less, just keep an eye on
>> http://download.osgeo.org/livedvd/4.0-rc5/
>> Thanks,
>> Alex

More information about the Osgeolive mailing list