[Live-demo] Problems with 10.5 and VirtualBox 5.1

Stephen Woodbridge woodbri at swoodbridge.com
Thu Jun 8 10:52:17 PDT 2017

Hi all,

I just tried to install OSGeo Live 10.5 on Windows using VirtualBox 5.1 
and ran into a bunch of problems. I will allow for that fact that this 
is my first attempt to do this, but want to document the issues.

1. Follow the link to get VirtualBox and installed it on Windows 10 
64-bit machine.

2. tried to install vmdk following the instruction, I could not get this 
to work. Issues are:
* VirtualBox Dialogs are different on 5.1, but could basically follow 
the intent.
* when I tried to start the VM it launches and I get black screen with _ 
cursor and nothing more. Powered off VM, restarted it, same result. 
Could not find a work-a-round to this issue

3. Created a new VM using the 32-bit iso. For some reason, VirtualBox 
would not allow me to create 64-bit VM, so its a good thing you supplied 
a 32-bit iso also.
* Launching this VM, fails with No boot disk error.
* Launching this VM and quickly hiting F12 key, brings up boot options 
and selecting "c" to boot from CD-ROM, boots into Linux installation Menu
* If you select "Try Linux without installing" from the menu, it brings 
up OSGeo Live, but no where are these steps documented and I tried menu 
options before discovering this.

4. Once in OSGeo Live, I could not access my shared folder. It took me 
some time to work around this but eventually this worked:

sudo umount /media/sf_SharedFolder
sudo chmod 777 /media/sf_SharedFolder
sudo mount -t vboxsf -o rw,nodev,uid=0,gid=120  SharedFolder 

I noticed the rc.local adds vboxsf group to user, but it does not appear 
in the user account:

user at osgeolive:/media/sf_SharedFolder$ id
uid=999(user) gid=999(user) 

I'll be using OSQeo Live at FOSS4G Boston to present the pgRouting Workshop.


This email has been checked for viruses by Avast antivirus software.

More information about the Osgeolive mailing list