[Live-demo] [GeoNetwork-users] GeoNetwork rarely starts

Angelos Tzotsos gcpp.kalxas at gmail.com
Thu Jun 8 02:45:52 PDT 2017


Although OSGeo-Live 10.0 lists 1.0 GB of RAM as minimum requirement, 
GeoNetwork requires much more to run properly.
This is why we have added a hint in that section of our download page: 


On 06/07/2017 11:27 PM, userdrake wrote:
> Hi all,
> I'm using OsGeoLive 10.0 with virtualBox (on Windows 8.1 machine). When I
> try to start geonetwork (using the link "Start GeoNetwork" inside the
> desktop folder "Web Services"), I wait a minute and then, when firefox
> opens, I always get an error (the classical error like there's no
> connection, and tells to try reloading the page). If I keep trying reloading
> the page for 4/5 times, then this error appears:
> --------------------
> Problem accessing /geonetwork/. Reason:
>      Service Unavailable
> Powered by Jetty://
> -------------------
> <http://osgeo-org.1560.x6.nabble.com/file/n5323416/_geonetwork_error.png>
> This error happens to me a lot of times. Rarely geonetwork starts correctly.
> I have tried also starting it from the command line and the result is this:
> ---------------------
> root at osgeolive:/usr/local/lib/geonetwork/bin# ./startup.sh
> rm: cannot remove 'logs/*request.log*': No such file or directory
> mv: cannot stat 'logs/geonetwork.log.*': No such file or directory
> mv: cannot stat 'logs/geoserver.log.*': No such file or directory
> ** (zenity:3648): WARNING **: Error retrieving accessibility bus address:
> org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not
> provided by any .service files
> Gtk-Message: GtkDialog mapped without a transient parent. This is
> discouraged.
> -----------------------
> *I have tried re-creating from scratch a new virtual machine with osgeolive,
> but the error still persists
> *Trying from the command line or by clicking the "start geonetwork" link,
> it's the same, the problem still persists.
> *The problem doesn't happen with geoserver, that always starts correctly.
> *I'm always conneted to the internet when I start it
> #I suspect (I would ask) if this problem could depend both on the quality of
> the connection and the hardware of the notebook. Some colleagues have the
> same problem but with a lower intensity than me. Most of the times (2 times)
> that geonetwork could start wasn't at home. I think also a good hardware
> could help. I have 4 gb of ram, AMD A6 6310 apu (1,60Ghz), Amd Radeon R4
> graphics, and I run osgeolive in virtualbox dedicating 1200 mb of RAM.
> Is there a solution that could help?
> Thank you very much for your time and consideration.
> Best
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/GeoNetwork-rarely-starts-tp5323416.html
> Sent from the GeoNetwork users mailing list archive at Nabble.com.
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> GeoNetwork-users mailing list
> GeoNetwork-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

Angelos Tzotsos, PhD
Charter Member
Open Source Geospatial Foundation

More information about the Osgeolive mailing list